summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-20 12:10:45 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-20 12:29:21 +0100
commitdb5d3c15667c2594197416903dfe38ffe1662a72 (patch)
tree34531a2438507abf6cb66a8cf3abb57bde1d1824 /dev-python/python-magic/python-magic-0.4.10.ebuild
parentdev-python/certifi: Version Bump (diff)
downloadgentoo-db5d3c15667c2594197416903dfe38ffe1662a72.tar.gz
gentoo-db5d3c15667c2594197416903dfe38ffe1662a72.tar.bz2
gentoo-db5d3c15667c2594197416903dfe38ffe1662a72.zip
dev-python/python-magic: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.10.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.10.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.10.ebuild b/dev-python/python-magic/python-magic-0.4.10.ebuild
new file mode 100644
index 000000000000..224d5965dc78
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/file[-python]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"