summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 16:17:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 17:47:01 -0500
commit1a32a4b37dfeba8a0abe263db5c27214cd55a6be (patch)
treeb305e6abf4aa565c68f3494d5d8d7a182b231bd5 /dev-python/python-manilaclient
parentdev-python/python-magnumclient: 2.12.0 bump (diff)
downloadgentoo-1a32a4b37dfeba8a0abe263db5c27214cd55a6be.tar.gz
gentoo-1a32a4b37dfeba8a0abe263db5c27214cd55a6be.tar.bz2
gentoo-1a32a4b37dfeba8a0abe263db5c27214cd55a6be.zip
dev-python/python-manilaclient: 1.27.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-manilaclient')
-rw-r--r--dev-python/python-manilaclient/Manifest1
-rw-r--r--dev-python/python-manilaclient/python-manilaclient-1.27.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/python-manilaclient/Manifest b/dev-python/python-manilaclient/Manifest
index 851999c870f7..35ee58b56e8b 100644
--- a/dev-python/python-manilaclient/Manifest
+++ b/dev-python/python-manilaclient/Manifest
@@ -1,2 +1,3 @@
DIST python-manilaclient-1.14.0.tar.gz 193535 BLAKE2B 33052c0c601d1a51f6200e5a05ddeeb96e57a174bf8adc929b848e99bce05764596ff5bf79922757d9b9d2785eff8c81681751f1b7bb6263d6d1eb88f8502e29 SHA512 9cfeffa8919af788b50b2753d722ee5472b45332a8e8dcfd290719344d1d6e7c7880ba0166ccc1c39b1eb15adaa1d8b012d923a04f4ba5b3a2a9774af981bb6a
DIST python-manilaclient-1.21.0.tar.gz 208720 BLAKE2B 62249b9d3ba22e77d59e060e372901fc3447f44e06c91236c74ba9c16b69bf52ebb8a186405dc2906177bc974df979507c8c9b085a81b8da61618cfc0a07d1fb SHA512 bedaf6d23968a36498e7cd4500f02540debe2b8aa1d7eb73b654c09f1da6a0e397fdd68b978c5e7706365354dbb42f7ddbcd0b2801f3ae706aaa7c2059a16c62
+DIST python-manilaclient-1.27.0.tar.gz 214632 BLAKE2B 5a0b6433712ae34f52b72838a771a6e81c7c28ff0b049f208bdf9b5fd311025ebe90e850b071def454f76245f19a28b27fea5dda59473f445e9882917eae90d9 SHA512 0dd621c8ff22abdf81177887fc8bc7b9792d637eabc092de06d5059ed3fcea0218961643a1e5256fd130e5d1753be143b474342d9daf5c8e5e39c305527ad811
diff --git a/dev-python/python-manilaclient/python-manilaclient-1.27.0.ebuild b/dev-python/python-manilaclient/python-manilaclient-1.27.0.ebuild
new file mode 100644
index 000000000000..c71c25f86a26
--- /dev/null
+++ b/dev-python/python-manilaclient/python-manilaclient-1.27.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Manila API"
+HOMEPAGE="https://github.com/openstack/python-manilaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ # built in...
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}