summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 16:55:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 17:13:36 -0500
commitd4db4c2d234884fdee02f321adc6ac5319ef9d3a (patch)
treef9d5e83d196945e84d85ee20b66c31d7894838a1 /dev-python/python-manilaclient
parentdev-python/python-monascaclient: 2.1.1 bump (diff)
downloadgentoo-d4db4c2d234884fdee02f321adc6ac5319ef9d3a.tar.gz
gentoo-d4db4c2d234884fdee02f321adc6ac5319ef9d3a.tar.bz2
gentoo-d4db4c2d234884fdee02f321adc6ac5319ef9d3a.zip
dev-python/python-manilaclient: 2.3.0 bump
Closes: https://bugs.gentoo.org/747250 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-manilaclient')
-rw-r--r--dev-python/python-manilaclient/Manifest1
-rw-r--r--dev-python/python-manilaclient/python-manilaclient-2.3.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/python-manilaclient/Manifest b/dev-python/python-manilaclient/Manifest
index cd2d14e4e2c0..c1a51c088ab3 100644
--- a/dev-python/python-manilaclient/Manifest
+++ b/dev-python/python-manilaclient/Manifest
@@ -1 +1,2 @@
DIST python-manilaclient-1.27.0.tar.gz 214632 BLAKE2B 5a0b6433712ae34f52b72838a771a6e81c7c28ff0b049f208bdf9b5fd311025ebe90e850b071def454f76245f19a28b27fea5dda59473f445e9882917eae90d9 SHA512 0dd621c8ff22abdf81177887fc8bc7b9792d637eabc092de06d5059ed3fcea0218961643a1e5256fd130e5d1753be143b474342d9daf5c8e5e39c305527ad811
+DIST python-manilaclient-2.3.0.tar.gz 263246 BLAKE2B 885ed636369d296b64bee91b8556be7059837a7958252fe0d24ae6fac7d3e04971539389113bdb06cf8223beb66370e93a3e834b5b8985edbb55b6c922cafdd0 SHA512 cedbf7aa4cce98bb46379dce70684ba3425d6fbd692cfe9878674cb8d7846bd536893fcbdd4c5dbd47e863cb509739433dff905413921ad17cce4e8123e593a9
diff --git a/dev-python/python-manilaclient/python-manilaclient-2.3.0.ebuild b/dev-python/python-manilaclient/python-manilaclient-2.3.0.ebuild
new file mode 100644
index 000000000000..6c86eecee187
--- /dev/null
+++ b/dev-python/python-manilaclient/python-manilaclient-2.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Manila API"
+HOMEPAGE="https://github.com/openstack/python-manilaclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-3.5.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/osc-lib-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+"