summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 20:43:23 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 20:47:22 +0200
commit75f718032408676c1f02dff0b07248abc0e9e762 (patch)
tree2025adf12598d40f87d6a666c4906d469cc28b69 /dev-python/python-memcached/python-memcached-1.58.ebuild
parentdev-python/webob: Bump (diff)
downloadgentoo-75f718032408676c1f02dff0b07248abc0e9e762.tar.gz
gentoo-75f718032408676c1f02dff0b07248abc0e9e762.tar.bz2
gentoo-75f718032408676c1f02dff0b07248abc0e9e762.zip
dev-python/python-memcached: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/python-memcached/python-memcached-1.58.ebuild')
-rw-r--r--dev-python/python-memcached/python-memcached-1.58.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/python-memcached/python-memcached-1.58.ebuild b/dev-python/python-memcached/python-memcached-1.58.ebuild
new file mode 100644
index 000000000000..a330a18a3205
--- /dev/null
+++ b/dev-python/python-memcached/python-memcached-1.58.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python memcached client"
+HOMEPAGE="http://www.tummy.com/Community/software/python-memcached/ https://pypi.python.org/pypi/python-memcached"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="OSL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ net-misc/memcached
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+# Tests try to connect to memcached via TCP/IP. Please do not re-enable
+# until you get them all to pass properly while using the UNIX socket
+# only and not even trying to connect to memcached over TCP/IP.
+RESTRICT=test
+
+python_test() {
+ # Note: partial. Needs fixing. Stuff like that.
+
+ cd "${TMPDIR}" || die
+
+ local memcached_opts=( -d -P memcached.pid -s memcached.socket )
+ [[ ${EUID} == 0 ]] && memcached_opts+=( -u portage )
+
+ memcached "${memached_opts[@]}" || die
+
+ "${PYTHON}" memcache.py --do-unix || die "Tests fail with ${EPYTHON}"
+
+ kill "$(<memcached.pid)" || die
+ rm memcached.pid || die
+}