summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-27 09:44:20 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-02-27 09:56:12 +0100
commit69323bfb4c2e76b2aabb818387b0000f82684cce (patch)
treec4ecbee6792fba4d78ff844efad882724a034060 /dev-python/python-mpv
parentnet-dialup/freeradius: add 3.2.1 (diff)
downloadgentoo-69323bfb4c2e76b2aabb818387b0000f82684cce.tar.gz
gentoo-69323bfb4c2e76b2aabb818387b0000f82684cce.tar.bz2
gentoo-69323bfb4c2e76b2aabb818387b0000f82684cce.zip
dev-python/python-mpv: add 1.0.2
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/python-mpv')
-rw-r--r--dev-python/python-mpv/Manifest1
-rw-r--r--dev-python/python-mpv/python-mpv-1.0.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-mpv/Manifest b/dev-python/python-mpv/Manifest
index 3fb93cebd68d..014a0708ee5c 100644
--- a/dev-python/python-mpv/Manifest
+++ b/dev-python/python-mpv/Manifest
@@ -1 +1,2 @@
DIST python-mpv-1.0.1.tar.gz 210008 BLAKE2B 3ba95ac4d3219615c80ea475c1f6dc3acd608a8ded919eea55efac8bb44a8946c959a2b39473e6c9e80fa1a4e52f525d6ef9871e3eb4b2664aeb1460208bc677 SHA512 16a6e93b63f30e535c1e3bd77702d7c703dd9c0a6a689f09e689663cac04e587bdc2135612062d791ffb38c709bc289d0297ebf9f1ddaf9b1771f25eae225f1b
+DIST python-mpv-1.0.2.gh.tar.gz 210975 BLAKE2B 1a364761405e430ed91f597e15aae7f6c221980c2ed9ce0152109486d1fb79ebb7b6257c79bfef34d72468bcf335e8e514324bdd10982096a64f8949b4bca261 SHA512 62a1c682de8d0308a80b66d6f435fba8563abc84b16670c3ef55cc3d9295fd3ead7c68d99e64c06734c5be9017549a53bd760ca201146427abcfbf7aca610b7a
diff --git a/dev-python/python-mpv/python-mpv-1.0.2.ebuild b/dev-python/python-mpv/python-mpv-1.0.2.ebuild
new file mode 100644
index 000000000000..194d0f3edd53
--- /dev/null
+++ b/dev-python/python-mpv/python-mpv-1.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to the mpv media player"
+HOMEPAGE="https://github.com/jaseg/python-mpv"
+SRC_URI="https://github.com/jaseg/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-video/mpv[libmpv]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="test? ( dev-python/xvfbwrapper[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # https://github.com/jaseg/python-mpv/issues/209
+ EPYTEST_DESELECT=(
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_negative
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_positive
+ tests/test_mpv.py::TestLifecycle::test_wait_for_property_shutdown
+ tests/test_mpv.py::TestLifecycle::test_wait_for_prooperty_event_overflow
+ tests/test_mpv.py::TestLifecycle::test_event_callback
+ )
+ virtx epytest
+}