summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 10:09:23 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 10:09:36 +0200
commite0d7f4de398958a5a8d33f7a676ca26dfa755e33 (patch)
tree16e65342bde192cefed927401bdffb6b57a0cf99 /dev-python/python-openid/python-openid-2.2.5-r1.ebuild
parentdev-python/mox: Remove last-rited pkg (diff)
downloadgentoo-e0d7f4de398958a5a8d33f7a676ca26dfa755e33.tar.gz
gentoo-e0d7f4de398958a5a8d33f7a676ca26dfa755e33.tar.bz2
gentoo-e0d7f4de398958a5a8d33f7a676ca26dfa755e33.zip
dev-python/python-openid: Remove last-rited pkg
Closes: https://bugs.gentoo.org/735178 Closes: https://bugs.gentoo.org/710036 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-openid/python-openid-2.2.5-r1.ebuild')
-rw-r--r--dev-python/python-openid/python-openid-2.2.5-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild b/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
deleted file mode 100644
index 5279018236b1..000000000000
--- a/dev-python/python-openid/python-openid-2.2.5-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_REQ_USE='sqlite?'
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="OpenID support for servers and consumers"
-HOMEPAGE="http://www.openidenabled.com/openid/libraries/python/ https://pypi.org/project/python-openid/"
-# Downloaded from https://github.com/openid/python-openid/downloads
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~ppc ppc64 s390 sparc x86"
-IUSE="examples mysql postgres sqlite test"
-
-RDEPEND="mysql? ( >=dev-python/mysql-python-1.2.2[${PYTHON_USEDEP}] )
- postgres? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}"
-S="${WORKDIR}/openid-python-openid-b666238"
-
-# Tests depend on twill, a broken package. Bug #285169
-RESTRICT="test"
-
-python_prepare_all() {
- local PATCHES=(
- # Patch to fix confusion with localhost/127.0.0.1
- "${FILESDIR}/${PN}-2.0.0-gentoo-test_fetchers.diff"
- "${FILESDIR}"/"${P}-tests.patch"
- )
-
- # Disable broken tests from from examples/djopenid.
- # Remove test that requires running db server.
- sed -e "s/django_failures =.*/django_failures = 0/" \
- -e '/storetest/d' \
- -i admin/runtests || die "sed admin/runtests failed"
-
- rm -v openid/test/test_parsehtml.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- "${PYTHON}" admin/runtests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}