summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-28 18:45:43 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-28 18:48:21 -0700
commit8d38cc5095f28f55b68c0f0bc5ec956eff45f354 (patch)
tree3ff78b7aea21552f0a81ca9b2dc156cae4ee9aec /dev-python/python-sshpubkeys
parentdev-python/yapf-0.30.0: Version bump (diff)
downloadgentoo-8d38cc5095f28f55b68c0f0bc5ec956eff45f354.tar.gz
gentoo-8d38cc5095f28f55b68c0f0bc5ec956eff45f354.tar.bz2
gentoo-8d38cc5095f28f55b68c0f0bc5ec956eff45f354.zip
dev-python/python-sshpubkeys: new package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/python-sshpubkeys')
-rw-r--r--dev-python/python-sshpubkeys/Manifest1
-rw-r--r--dev-python/python-sshpubkeys/metadata.xml8
-rw-r--r--dev-python/python-sshpubkeys/python-sshpubkeys-3.1.0.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-sshpubkeys/Manifest b/dev-python/python-sshpubkeys/Manifest
new file mode 100644
index 000000000000..90314609466a
--- /dev/null
+++ b/dev-python/python-sshpubkeys/Manifest
@@ -0,0 +1 @@
+DIST python-sshpubkeys-3.1.0.tar.gz 55289 BLAKE2B bf1836c173b542f0edc8dc0635a1f5bf109ef95936ffbabf6bbb79ac3bc34c10a769733d622c338b1f3a87d5be84b89ea9779f7fa293cad706f364d5e8867afc SHA512 4f07cb7bd2b1839a63bff842660499cee816e8675d8fde1e84ee567e354c82677a69e539b99505c6d1c5e0e7a5962a36175eb0cfcc763886a33952d2346c3405
diff --git a/dev-python/python-sshpubkeys/metadata.xml b/dev-python/python-sshpubkeys/metadata.xml
new file mode 100644
index 000000000000..56cae167d372
--- /dev/null
+++ b/dev-python/python-sshpubkeys/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-sshpubkeys/python-sshpubkeys-3.1.0.ebuild b/dev-python/python-sshpubkeys/python-sshpubkeys-3.1.0.ebuild
new file mode 100644
index 000000000000..21e44f995cd5
--- /dev/null
+++ b/dev-python/python-sshpubkeys/python-sshpubkeys-3.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="OpenSSH public key parser for Python"
+HOMEPAGE="https://pypi.org/project/sshpubkeys/ https://github.com/ojarva/python-sshpubkeys"
+SRC_URI="https://github.com/ojarva/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/ecdsa[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/twine[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest