summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-11 12:57:32 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-11 13:06:31 -0600
commitce7db71af734d1bbb682ea1fee2669e586163665 (patch)
tree5b35e4bd8ec82a531aa549be6d233b22452b0130 /dev-python/python-troveclient
parentdev-python/python-octaviaclient: cleanup (diff)
downloadgentoo-ce7db71af734d1bbb682ea1fee2669e586163665.tar.gz
gentoo-ce7db71af734d1bbb682ea1fee2669e586163665.tar.bz2
gentoo-ce7db71af734d1bbb682ea1fee2669e586163665.zip
dev-python/python-troveclient: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/python-troveclient')
-rw-r--r--dev-python/python-troveclient/Manifest1
-rw-r--r--dev-python/python-troveclient/python-troveclient-2.5.0.ebuild56
2 files changed, 0 insertions, 57 deletions
diff --git a/dev-python/python-troveclient/Manifest b/dev-python/python-troveclient/Manifest
index ded2814e54d0..c775e829ee8a 100644
--- a/dev-python/python-troveclient/Manifest
+++ b/dev-python/python-troveclient/Manifest
@@ -1,2 +1 @@
DIST python-troveclient-2.17.0.tar.gz 189560 BLAKE2B 680d76af88b8242956eb8e7a8644c11b47fee785eb0940bca1d3b8c5c500c3c233ac0e452d7a609d10028571e68ad52d47d3834898e98642cbb93b0b17f0db40 SHA512 b314115d2c50c87658b02f5dfe9a22f68cb31ba89c3baedf45bf87c4f482aeb235c751753da538bb38c514600b374b1d3f43e17d4a8b929738b4c742e28c63d8
-DIST python-troveclient-2.5.0.tar.gz 149926 BLAKE2B 11acb39afed5ed018a83861fa344e1d482bfa179e0bce97e517e392daf982d868b0c24aeae2406732ddb39e71ab977832df76b55354975d671ee17421cca72cd SHA512 83e7cafec8ce4d65a55d8854bc2e2fbc657d567e4dc2b42a64c527c656ba5f253839511582c5ca2dda970bebb4555390b895a882b87a2eacb86ccbfac9c09a97
diff --git a/dev-python/python-troveclient/python-troveclient-2.5.0.ebuild b/dev-python/python-troveclient/python-troveclient-2.5.0.ebuild
deleted file mode 100644
index e26f23e9d4e8..000000000000
--- a/dev-python/python-troveclient/python-troveclient-2.5.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A client for the OpenStack Trove API, a scalable relational database service"
-HOMEPAGE="https://github.com/openstack/python-troveclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/requests-mock-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/httplib2-0.7.5[${PYTHON_USEDEP}]
- >=dev-python/pycrypto-2.6[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
- >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
- >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
- >=dev-python/keystoneauth-2.10.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/python-swiftclient-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/python-mistralclient-2.0.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- testr init
- testr run --parallel || die "testsuite failed under python2.7"
-}