summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gmail.com>2021-08-06 10:26:58 +0300
committerMichał Górny <mgorny@gentoo.org>2021-08-07 14:16:15 +0200
commitbf24c85c94705e3a33a2357786176b8e00464ff7 (patch)
treee9b1b8b32f5a11a13471e70c80e4b4d43acd17f4 /dev-python/python3-saml
parentdev-python/pysmi: enable doc generation (diff)
downloadgentoo-bf24c85c94705e3a33a2357786176b8e00464ff7.tar.gz
gentoo-bf24c85c94705e3a33a2357786176b8e00464ff7.tar.bz2
gentoo-bf24c85c94705e3a33a2357786176b8e00464ff7.zip
dev-python/python3-saml: add 1.11.0
- enable py3.10 - bump to EAPI=8 - remove `dev-python/defusedxml` dependency, unneeded from new versions Signed-off-by: Arthur Zamarin <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python3-saml')
-rw-r--r--dev-python/python3-saml/Manifest1
-rw-r--r--dev-python/python3-saml/python3-saml-1.11.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/python3-saml/Manifest b/dev-python/python3-saml/Manifest
index 59e40f53dda3..e63e20c6ee2d 100644
--- a/dev-python/python3-saml/Manifest
+++ b/dev-python/python3-saml/Manifest
@@ -1,3 +1,4 @@
DIST python3-saml-1.10.0.tar.gz 503005 BLAKE2B 88be9b00082d00c86081432dd6789c0f040e8e210d3d1de218f8bf7a41cf32acce6aa90f92b6e083142a2a5c8f820eb9f8b6e880e742400b8bb83e7eb28db392 SHA512 82d15ef4315d25b38506177cbb4ef095a0546705035491847597b353486e119026c700f5d4d22764c93646f645e13d93d75bd3541c2c5b31343bcee35a42ead3
DIST python3-saml-1.10.1.tar.gz 503178 BLAKE2B 6c87f26db03799ee92211baf1216751c293ae6182d8f8abb094fcc47c2c28ca7be933b64b0dc3cbd52ea55a0cd19c4fc96a71bb89839d41fdd3eb3daee21d293 SHA512 64bd3fc11749ef8340fa59788277e5213edec6d93f7924e412e517846623dce88b97c407ca7ae0d58172cc78a8b713c2916fe5c29df3419fa10f34b84bdb549c
+DIST python3-saml-1.11.0.tar.gz 506373 BLAKE2B 909244e18b6ccb3cd0ed0059e387c14eb75a1a0fb709bdbc33f6dbcdda5b70359e6fedd77ab88e580aaf28503ca3f3fe49308f56338a1d8855149a7ba992034d SHA512 9e54eee28e2b6430d9f08342c312997b6a20f85e3f663573b93c4d8d65a6540c7d6f4e05d35314014b20ba080110a2a51718ac6754ef2b19bfe23d2d4381de24
DIST python3-saml-1.9.0.tar.gz 497106 BLAKE2B c3b282be835dcd0590125563ed0380bbb5d486aeffd60fa0d6a1e7d22b25ffaa03a1bea555520b1465b27b352df0936d21b919ce73a3671d63f07a52b3efdb37 SHA512 a5171258b917c02f10a0c420a19fe6829a034df1dfd87135351b9c187314dca2f973012f49056f391444aba76306adfd48cd77a859274d5cbd2a8c23a00af78d
diff --git a/dev-python/python3-saml/python3-saml-1.11.0.ebuild b/dev-python/python3-saml/python3-saml-1.11.0.ebuild
new file mode 100644
index 000000000000..0d7e03a43ba0
--- /dev/null
+++ b/dev-python/python3-saml/python3-saml-1.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="OneLogin's SAML Python Toolkit"
+HOMEPAGE="https://github.com/onelogin/python3-saml
+ https://pypi.org/project/python3-saml/"
+SRC_URI="https://github.com/onelogin/python3-saml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/isodate-0.5.0[${PYTHON_USEDEP}]
+ >=dev-python/lxml-3.3.5[${PYTHON_USEDEP}]
+ >=dev-python/python-xmlsec-1.0.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests setup.py
+
+src_prepare() {
+ # unpin deps
+ sed -i -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}