summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/pythondialog
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/pythondialog')
-rw-r--r--dev-python/pythondialog/Manifest2
-rw-r--r--dev-python/pythondialog/metadata.xml8
-rw-r--r--dev-python/pythondialog/pythondialog-3.2.2.ebuild36
-rw-r--r--dev-python/pythondialog/pythondialog-3.3.0.ebuild36
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pythondialog/Manifest b/dev-python/pythondialog/Manifest
new file mode 100644
index 000000000000..a7df16bf9e5e
--- /dev/null
+++ b/dev-python/pythondialog/Manifest
@@ -0,0 +1,2 @@
+DIST python3-pythondialog-3.2.2.tar.bz2 1412368 SHA256 bb104bd0512f9eda046b0cda53b5607d68de72b585cd8d5a1eebd549d8f2af99 SHA512 58b84c0dd7b71ec9d1e60c4802cfc8e6cc72f79b8b6accd387553c685a92367d242746065bac6cb1c9d501ac291d9307cb2bb6b26694e9f24a3c5d6637a5bb8e WHIRLPOOL 8e899f910eaaa5112403aed8adcd2e8fc9db371a5023bafdb5d2645b2ade716710b1c826d9208055fc510e8777751f8a43ef501db11c04827b93cb3040f4d793
+DIST python3-pythondialog-3.3.0.tar.bz2 1827891 SHA256 e4ace5b09d712992b7327249e375e49608127666679b2ca9fd48141e218ec998 SHA512 b651593f077f6679be030182ac5f14a02d8bad86206c2733ba8b655d346809a32ea391de91e35101d400c55d9e8ecefaf6f1ba25fec036246186e13530f43a1f WHIRLPOOL 267a2ee4215fd53d7faaf88a02ee544e88eafdd5b1f4c45c4ba535fe46dbed41a1ebae72b0dae00fedb30cfb1fcd245e0439077f538d128137e8c8caca6bba70
diff --git a/dev-python/pythondialog/metadata.xml b/dev-python/pythondialog/metadata.xml
new file mode 100644
index 000000000000..fc12076b9b0b
--- /dev/null
+++ b/dev-python/pythondialog/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="sourceforge">pythondialog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pythondialog/pythondialog-3.2.2.ebuild b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
new file mode 100644
index 000000000000..896573b9dc05
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+IUSE="doc examples"
+
+RDEPEND="dev-util/dialog"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pythondialog/pythondialog-3.3.0.ebuild b/dev-python/pythondialog/pythondialog-3.3.0.ebuild
new file mode 100644
index 000000000000..db6497f13f56
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.3.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-util/dialog"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}