summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-30 04:57:03 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-30 05:06:59 +0100
commit18174aca57663ca5cbafc3b5af75a6bfb77fc93f (patch)
tree8f6a94b60c3903723920b79a9079a8c444fe2b87 /dev-python/pythonfinder/pythonfinder-2.1.0.ebuild
parentdev-python/referencing: Bump to 0.33.0 (diff)
downloadgentoo-18174aca57663ca5cbafc3b5af75a6bfb77fc93f.tar.gz
gentoo-18174aca57663ca5cbafc3b5af75a6bfb77fc93f.tar.bz2
gentoo-18174aca57663ca5cbafc3b5af75a6bfb77fc93f.zip
dev-python/pythonfinder: Bump to 2.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pythonfinder/pythonfinder-2.1.0.ebuild')
-rw-r--r--dev-python/pythonfinder/pythonfinder-2.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild b/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild
new file mode 100644
index 000000000000..f68a9f5ef322
--- /dev/null
+++ b/dev-python/pythonfinder/pythonfinder-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PythonFinder: Cross Platform Search Tool for Finding Pythons"
+HOMEPAGE="
+ https://github.com/sarugaku/pythonfinder/
+ https://pypi.org/project/pythonfinder/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}