summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-27 23:48:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-28 17:52:50 +0200
commit17721ada8edc9462e7c7a0e11f58b13eef9031ff (patch)
tree8ebe08d6b2826596c9d385f1cf4a6ac6b0bb7e63 /dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild
parentdev-python/pymongo: Remove py2.7 in revbump (diff)
downloadgentoo-17721ada8edc9462e7c7a0e11f58b13eef9031ff.tar.gz
gentoo-17721ada8edc9462e7c7a0e11f58b13eef9031ff.tar.bz2
gentoo-17721ada8edc9462e7c7a0e11f58b13eef9031ff.zip
dev-python/pyyaml: Remove py2.7 in revbump
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild')
-rw-r--r--dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild b/dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild
new file mode 100644
index 000000000000..5cef66731ae0
--- /dev/null
+++ b/dev-python/pyyaml/pyyaml-5.3.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="YAML parser and emitter for Python"
+HOMEPAGE="https://pyyaml.org/wiki/PyYAML
+ https://pypi.org/project/PyYAML/
+ https://github.com/yaml/pyyaml"
+SRC_URI="https://github.com/yaml/pyyaml/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="examples +libyaml"
+
+RDEPEND="libyaml? ( dev-libs/libyaml:= )"
+DEPEND="${RDEPEND}
+ libyaml? (
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')
+ )"
+
+PATCHES=(
+ # bug #659348
+ "${FILESDIR}/pyyaml-5.1-cve-2017-18342.patch"
+)
+
+distutils_enable_tests setup.py
+
+python_configure_all() {
+ mydistutilsargs=( $(use_with libyaml) )
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}
+ fi
+}