summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 15:59:02 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 16:10:58 +0100
commit978b04a3c85fd8727a4b5ee303be22e4cd1abe23 (patch)
tree8e73b2522fdf201096800a0a094a6c373cd620d2 /dev-python/pyyaml
parentdev-python/markdown: Remove py2.7 (diff)
downloadgentoo-978b04a3c85fd8727a4b5ee303be22e4cd1abe23.tar.gz
gentoo-978b04a3c85fd8727a4b5ee303be22e4cd1abe23.tar.bz2
gentoo-978b04a3c85fd8727a4b5ee303be22e4cd1abe23.zip
dev-python/pyyaml: Remove old (py2)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml')
-rw-r--r--dev-python/pyyaml/pyyaml-5.3.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pyyaml/pyyaml-5.3.1.ebuild b/dev-python/pyyaml/pyyaml-5.3.1.ebuild
deleted file mode 100644
index 8cfda4144296..000000000000
--- a/dev-python/pyyaml/pyyaml-5.3.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="YAML parser and emitter for Python"
-HOMEPAGE="https://pyyaml.org/wiki/PyYAML
- https://pypi.org/project/PyYAML/
- https://github.com/yaml/pyyaml"
-SRC_URI="https://github.com/yaml/pyyaml/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="examples +libyaml"
-
-RDEPEND="libyaml? ( dev-libs/libyaml:= )"
-DEPEND="${RDEPEND}
- libyaml? (
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
- )"
-
-PATCHES=(
- # bug #659348
- "${FILESDIR}/pyyaml-5.1-cve-2017-18342.patch"
-)
-
-distutils_enable_tests setup.py
-
-python_configure_all() {
- mydistutilsargs=( $(use_with libyaml) )
-}
-
-python_install_all() {
- distutils-r1_python_install_all
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}
- fi
-}