summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-11 15:09:26 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-06-11 15:43:15 +0200
commiteb4b3342446d7f8f28f46bec87c0483e3f14a65c (patch)
treec27e3c53386b34b267b80499773afbd17be49281 /dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild
parentdev-python/ghp-import: add new dep of mkdocs (diff)
downloadgentoo-eb4b3342446d7f8f28f46bec87c0483e3f14a65c.tar.gz
gentoo-eb4b3342446d7f8f28f46bec87c0483e3f14a65c.tar.bz2
gentoo-eb4b3342446d7f8f28f46bec87c0483e3f14a65c.zip
dev-python/pyyaml_env_tag: add new dep of mkdocs
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild')
-rw-r--r--dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild b/dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild
new file mode 100644
index 000000000000..4abd9f92c604
--- /dev/null
+++ b/dev-python/pyyaml_env_tag/pyyaml_env_tag-0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="A custom YAML tag for referencing environment variables in YAML files"
+HOMEPAGE="https://github.com/waylan/pyyaml-env-tag"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest