summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-04 08:54:00 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-04 09:57:19 +0100
commit445e572b9d18a2b935071529869f8caf6a92ba80 (patch)
tree0db2744072668f0c44938f9382ecc420b2b734c5 /dev-python/pyzmq
parentdev-python/hypothesis: Bump to 6.4.2 (diff)
downloadgentoo-445e572b9d18a2b935071529869f8caf6a92ba80.tar.gz
gentoo-445e572b9d18a2b935071529869f8caf6a92ba80.tar.bz2
gentoo-445e572b9d18a2b935071529869f8caf6a92ba80.zip
dev-python/pyzmq: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzmq')
-rw-r--r--dev-python/pyzmq/Manifest1
-rw-r--r--dev-python/pyzmq/pyzmq-19.0.2.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/pyzmq/Manifest b/dev-python/pyzmq/Manifest
index efb9b0bf0edb..4257e611c47a 100644
--- a/dev-python/pyzmq/Manifest
+++ b/dev-python/pyzmq/Manifest
@@ -1,2 +1 @@
-DIST pyzmq-19.0.2.tar.gz 390927 BLAKE2B d70a2f615782cc5a53ed2ffab4d5549bc5d15cc1e0e63f640a357fe8575ca327a5976a3e8b11d97c236a31ca17025f37fe423d166b684b5c4aafc139a0941492 SHA512 7f077ed3858c226eb1e3f5e51dfb5d4b517ec94357b37cc66d17cfe2543786b86627ce7eb4c12785a2709a499af998d02642d972c119a637df3cec5201e909d1
DIST pyzmq-20.0.0.gh.tar.gz 393041 BLAKE2B 1f22f556f5d0f2755c2e56411fdb9f583bbdfad6315e4e72fbaa1fb18d0ad5436ee0ee8d17497641421cea3f4e1b53b8ff85bf7ced96c8f1c80db0be901ca3d5 SHA512 30359e501e76d6ec14175622d6c970d9ec0f227b372d2b1c6e6650be812dd47017b797a016f5a2da83f72d00536e64d2f005a38003c9a1b4fbb7266f2640782d
diff --git a/dev-python/pyzmq/pyzmq-19.0.2.ebuild b/dev-python/pyzmq/pyzmq-19.0.2.ebuild
deleted file mode 100644
index 8e03f123eab8..000000000000
--- a/dev-python/pyzmq/pyzmq-19.0.2.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit flag-o-matic distutils-r1 toolchain-funcs
-
-EGIT_COMMIT="dd4dac055152d47c829034224cdecf594c7b3f12"
-DESCRIPTION="Lightweight and super-fast messaging library built on top of the ZeroMQ library"
-HOMEPAGE="
- https://www.zeromq.org/bindings:python
- https://pypi.org/project/pyzmq/
- https://github.com/zeromq/pyzmq/"
-SRC_URI="
- https://github.com/zeromq/pyzmq/archive/${EGIT_COMMIT}.tar.gz
- -> ${P}.tar.gz"
-S=${WORKDIR}/${PN}-${EGIT_COMMIT}
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~mips ~ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
-IUSE="+draft"
-
-DEPEND="
- >=net-libs/zeromq-4.2.2-r2:=[drafts]
-"
-RDEPEND="${DEPEND}
- dev-python/py[${PYTHON_USEDEP}]
- dev-python/cffi:=[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/cython[${PYTHON_USEDEP}]
- test? (
- >=www-servers/tornado-5.0.2[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- "dev-python/numpydoc"
-
-python_configure_all() {
- tc-export CC
- append-cppflags -DZMQ_BUILD_DRAFT_API=$(usex draft '1' '0')
-}
-
-python_compile() {
- esetup.py cython --force
- distutils-r1_python_compile
-}
-
-python_test() {
- local deselect=(
- # lore says it sometimes hangs
- zmq/tests/test_auth.py::TestThreadAuthentication::test_curve
-
- # broken tests
- zmq/tests/test_auth.py::TestThreadAuthentication::test_curve_user_id
- zmq/tests/test_constants.py::TestConstants::test_draft
- zmq/tests/test_context.py::TestContext::test_mockable
- zmq/tests/test_draft.py::TestDraftSockets::test_client_server
- zmq/tests/test_draft.py::TestDraftSockets::test_radio_dish
- zmq/tests/test_message.py::TestFrame::test_buffer_numpy
- zmq/tests/test_message.py::TestFrame::test_bytes
- zmq/tests/test_message.py::TestFrame::test_frame_more
- zmq/tests/test_message.py::TestFrame::test_lifecycle1
- zmq/tests/test_message.py::TestFrame::test_lifecycle2
- zmq/tests/test_message.py::TestFrame::test_memoryview_shape
- zmq/tests/test_message.py::TestFrame::test_multi_tracker
- zmq/tests/test_message.py::TestFrame::test_tracker
- zmq/tests/test_security.py::TestSecurity::test_curve
- zmq/tests/test_security.py::TestSecurity::test_plain
- zmq/tests/test_socket.py::TestSocket::test_large_send
- zmq/tests/test_socket.py::TestSocket::test_tracker
- zmq/tests/test_socket.py::TestSocketGreen::test_large_send
-
- # hanging tests
- zmq/tests/test_socket.py::TestSocketGreen::test_tracker
- zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_blacklist
- zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_curve
- zmq/tests/asyncio/test_asyncio.py::TestAsyncioAuthentication::test_plain
- )
- [[ ${EPYTHON} == python3.9 ]] && deselect+=(
- # crashes python
- zmq/tests/test_socket.py::TestSocketGreen
- )
-
- pytest -vv ${deselect[@]/#/--deselect } ||
- die "Tests failed with ${EPYTHON}"
-}