summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:30:04 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:41 +0200
commitea501af4276b64db57ce20c21f1d066fce732131 (patch)
tree21f470e13d6ea22196b43671bc5b31803312135c /dev-python/pyzotero
parentdev-python/stripe: Bump to 9.7.0 (diff)
downloadgentoo-ea501af4276b64db57ce20c21f1d066fce732131.tar.gz
gentoo-ea501af4276b64db57ce20c21f1d066fce732131.tar.bz2
gentoo-ea501af4276b64db57ce20c21f1d066fce732131.zip
dev-python/pyzotero: Bump to 1.5.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyzotero')
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.5.19.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index dca07ac3c047..f1069734c7d1 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
DIST pyzotero-1.5.18.tar.gz 527435 BLAKE2B 27ab1ccf32c260098a684ce4ee05c9acdedec787ec268ebe994d4e9904b9aae73c4a48bb169ec84d727d780c2168e177bcb47209d0f09dc661dd990f1a4075db SHA512 c45e18de0ed479b0ce03cc69ec7a2b060370d6c26e57fa707d2230078e87cdb9eb70f341bac8533a9fa6f4101f29aeca8767befa1e275c0dbd7e778e9c227c21
+DIST pyzotero-1.5.19.tar.gz 527472 BLAKE2B 3cd188812f44d4f3d77fb74c7a2e915969f835a941234b60975d11435d651408cb86462ba684a607698ab634138389999796749217be8b4db1bdd8a9b3dffd8c SHA512 ffb466592f96f2af5775d7b57da3dd314809605c57a1fcbe863003eed1774e9bf89d99e3bc549c61fbaf29a0d520c0eaa767ff0dd9cdaae538a6880018b6347e
diff --git a/dev-python/pyzotero/pyzotero-1.5.19.ebuild b/dev-python/pyzotero/pyzotero-1.5.19.ebuild
new file mode 100644
index 000000000000..9f5c51eba660
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.5.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="
+ https://github.com/urschrei/pyzotero/
+ https://pypi.org/project/pyzotero/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-6.0.11[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.21.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest