summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2019-12-16 09:55:10 +0100
committerBenda Xu <heroxbd@gentoo.org>2019-12-23 16:10:56 +0800
commitff6f9d9ccdaa3337e90f23b119e0e531c1ce4fb3 (patch)
treeed1b76713224a3da02f92449ac3be3bb97e2f44a /dev-python/qtconsole
parentdev-python/ipykernel: Version bump 5.1.3. (diff)
downloadgentoo-ff6f9d9ccdaa3337e90f23b119e0e531c1ce4fb3.tar.gz
gentoo-ff6f9d9ccdaa3337e90f23b119e0e531c1ce4fb3.tar.bz2
gentoo-ff6f9d9ccdaa3337e90f23b119e0e531c1ce4fb3.zip
dev-python/qtconsole: Version bump 4.6.0.
Bug: https://github.com/gentoo/gentoo/pull/13988 Bug: https://bugs.gentoo.org/702458 Closes: https://github.com/gentoo/gentoo/pull/14008 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org> Package-Manager: Portage-2.3.81, Repoman-2.3.20
Diffstat (limited to 'dev-python/qtconsole')
-rw-r--r--dev-python/qtconsole/Manifest1
-rw-r--r--dev-python/qtconsole/qtconsole-4.6.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/qtconsole/Manifest b/dev-python/qtconsole/Manifest
index 68c47c9bf6b0..e0cf622b4c7b 100644
--- a/dev-python/qtconsole/Manifest
+++ b/dev-python/qtconsole/Manifest
@@ -1 +1,2 @@
DIST qtconsole-4.3.1.tar.gz 416931 BLAKE2B ec47c2ae8527d7aee55d6cb8d2ebea39ab1bfd3a268c46306613b67f72c27904db1de52682a47d075d804dad9cd7c124296163b39532936fb1a497ae606b7ffc SHA512 f0f84d95143b4513c3d12af4712c6a5724143bf8c44e7a3fbc06d7a94e665b8d12072dd13eafb09476a3aa829155f4c75eb517ffb2bd6e8bd3c00af3c764e48f
+DIST qtconsole-4.6.0.tar.gz 426936 BLAKE2B dfd61258e2e8a0ba74421253f39392e2daa04acfd072361488fc93087e2aa4daa62203e4da501a24db43a79eafe7eaa8528f54edbf7b6bb6d547521cc92b8829 SHA512 196022af0d9ebe9e065bf46c07f90bddb2c314d4f0f778f828e20200b11085150ff3ad3adac944496b778b926a0ccdec7903de27be25b79be7fe3ba867148b0b
diff --git a/dev-python/qtconsole/qtconsole-4.6.0.ebuild b/dev-python/qtconsole/qtconsole-4.6.0.ebuild
new file mode 100644
index 000000000000..1463903122d3
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-4.6.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ >=dev-python/sphinx-1.3.1-r1[${PYTHON_USEDEP}]
+ )
+ dev-python/PyQt5[${PYTHON_USEDEP},svg]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-13[${PYTHON_USEDEP}]
+ "
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}