summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rackspace-monitoring
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rackspace-monitoring')
-rw-r--r--dev-python/rackspace-monitoring/Manifest1
-rw-r--r--dev-python/rackspace-monitoring/metadata.xml16
-rw-r--r--dev-python/rackspace-monitoring/rackspace-monitoring-0.6.5.ebuild34
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/rackspace-monitoring/Manifest b/dev-python/rackspace-monitoring/Manifest
new file mode 100644
index 000000000000..7213122b55f2
--- /dev/null
+++ b/dev-python/rackspace-monitoring/Manifest
@@ -0,0 +1 @@
+DIST rackspace-monitoring-0.6.5.tar.gz 31397 SHA256 28e91f1054a9fe3b130c9d4fd65cb007e8efdaa89e9d8a8e99479aec73e298c4 SHA512 513e02eb7b823ed4287462ffe6517011c389119dbf37d90df31cc08714f93806188d07e4f8d339453b59f17c067229a3f52f1ae7aaf13a7c6504c0ef63b1f4fe WHIRLPOOL f90a4cfe2d13d4e68c9cfddaf9e6f94e3c721688d82059eeaa722e60278a040cbd87ae92e6d5c492b59fd7dc92e7ed302b690bc7fda4638e0e01ba22610903df
diff --git a/dev-python/rackspace-monitoring/metadata.xml b/dev-python/rackspace-monitoring/metadata.xml
new file mode 100644
index 000000000000..22de5298d962
--- /dev/null
+++ b/dev-python/rackspace-monitoring/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ Client library for Rackspace Cloud Monitoring.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">rackspace-monitoring</remote-id>
+ <remote-id type="github">racker/rackspace-monitoring</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/rackspace-monitoring/rackspace-monitoring-0.6.5.ebuild b/dev-python/rackspace-monitoring/rackspace-monitoring-0.6.5.ebuild
new file mode 100644
index 000000000000..6807e729b3fe
--- /dev/null
+++ b/dev-python/rackspace-monitoring/rackspace-monitoring-0.6.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Client library for Rackspace Cloud Monitoring"
+HOMEPAGE="https://github.com/racker/rackspace-monitoring"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+TEST_DEPENDS="dev-python/pep8[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
+ <dev-python/libcloud-0.16.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${TEST_DEPENDS}
+ ${RDEPEND}
+ )
+"
+
+python_test() {
+ ${EPYTHON} setup.py test || die
+}