summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 13:43:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 14:09:26 +0100
commit9f5fac1568d3b33c88d22da3e879ab5fdd1e7753 (patch)
tree09102c2101f408bc0dc938f89287ce42fca115ff /dev-python/rcssmin
parentdev-python/quantities: Switch to PEP 517 build (diff)
downloadgentoo-9f5fac1568d3b33c88d22da3e879ab5fdd1e7753.tar.gz
gentoo-9f5fac1568d3b33c88d22da3e879ab5fdd1e7753.tar.bz2
gentoo-9f5fac1568d3b33c88d22da3e879ab5fdd1e7753.zip
dev-python/rcssmin: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rcssmin')
-rw-r--r--dev-python/rcssmin/rcssmin-1.1.0-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rcssmin/rcssmin-1.1.0-r1.ebuild b/dev-python/rcssmin/rcssmin-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..414a710c2392
--- /dev/null
+++ b/dev-python/rcssmin/rcssmin-1.1.0-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="CSS minifier written in python"
+HOMEPAGE="http://opensource.perlig.de/rcssmin/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ export SETUP_CEXT_REQUIRED=1
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ mv "${D}/usr/share/doc/${PN}" "${D}/usr/share/doc/${PF}"
+}