summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-06-26 03:56:55 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-06-26 03:57:21 -0700
commitd70e7e9cf3c972c7a85be57a314f148790058035 (patch)
tree677a6db9c87cb4c93b05c1532ed4dae7ed2b705a /dev-python/reflink
parentnet-wireless/gr-paint: Source repo https://github.com/drmpeg/gr-paint38.git n... (diff)
downloadgentoo-d70e7e9cf3c972c7a85be57a314f148790058035.tar.gz
gentoo-d70e7e9cf3c972c7a85be57a314f148790058035.tar.bz2
gentoo-d70e7e9cf3c972c7a85be57a314f148790058035.zip
dev-python/reflink: drop 0.2.1-r2
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python/reflink')
-rw-r--r--dev-python/reflink/reflink-0.2.1-r2.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/reflink/reflink-0.2.1-r2.ebuild b/dev-python/reflink/reflink-0.2.1-r2.ebuild
deleted file mode 100644
index 11eb61de3fe4..000000000000
--- a/dev-python/reflink/reflink-0.2.1-r2.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 2019-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper around the reflink system calls"
-HOMEPAGE="https://gitlab.com/rubdos/pyreflink"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-RDEPEND="virtual/python-cffi[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-BDEPEND="${RDEPEND}
- test? ( sys-fs/btrfs-progs )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -e 's|'\''pytest-runner'\'',\?||' -i setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local notestmsg="Tests need FEATURES='-usersandbox -userpriv -sandbox'"
- if [[ ${EUID} != 0 ]]; then
- ewarn "${notestmsg}"
- elif
- has sandbox ${FEATURES}; then
- ewarn "${notestmsg}"
- else
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- # module import will fail with any other directory structure
- cp -rv "${S}"/tests ./ || die
- pytest -vv || die "Tests fail with ${EPYTHON}"
- popd >/dev/null || die
- fi
-}