summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-05 09:30:45 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-05 09:30:45 +0200
commitd9fb38dd859f2957729579c1f244f92164ff40b2 (patch)
treebc7518654091cb5eefd6dbea91360699508a9f55 /dev-python/regex/regex-2021.4.4.ebuild
parentdev-python/exdown: Bump to 0.8.8 (diff)
downloadgentoo-d9fb38dd859f2957729579c1f244f92164ff40b2.tar.gz
gentoo-d9fb38dd859f2957729579c1f244f92164ff40b2.tar.bz2
gentoo-d9fb38dd859f2957729579c1f244f92164ff40b2.zip
dev-python/regex: Bump to 2021.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/regex/regex-2021.4.4.ebuild')
-rw-r--r--dev-python/regex/regex-2021.4.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/regex/regex-2021.4.4.ebuild b/dev-python/regex/regex-2021.4.4.ebuild
new file mode 100644
index 000000000000..1ffe778404ae
--- /dev/null
+++ b/dev-python/regex/regex-2021.4.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Alternative regular expression module to replace re"
+HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="doc"
+
+python_test() {
+ eunittest -s "${BUILD_DIR}"/lib
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/Features.html )
+ local DOCS=( README.rst docs/*.rst )
+
+ distutils-r1_python_install_all
+}