summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-10-04 20:50:59 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-10-04 21:25:24 +0200
commit79e2fe8673b1b0703afba4ac15aa349a22efb8ed (patch)
tree29a705d7fd0be9bbeaf435d255c3b88195aca2ba /dev-python/reno/reno-3.2.0.ebuild
parentdev-util/ostree: Version updated to 2020.6. (diff)
downloadgentoo-79e2fe8673b1b0703afba4ac15aa349a22efb8ed.tar.gz
gentoo-79e2fe8673b1b0703afba4ac15aa349a22efb8ed.tar.bz2
gentoo-79e2fe8673b1b0703afba4ac15aa349a22efb8ed.zip
dev-python/reno: bump to 3.2.0, add Python 3.9 support+tests
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/reno/reno-3.2.0.ebuild')
-rw-r--r--dev-python/reno/reno-3.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/reno/reno-3.2.0.ebuild b/dev-python/reno/reno-3.2.0.ebuild
new file mode 100644
index 000000000000..3a693a7badac
--- /dev/null
+++ b/dev-python/reno/reno-3.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc needs to be built from a git repository
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Some tests need to be run from a git repository
+ rm reno/tests/test_{cache,semver}.py || die
+ distutils-r1_python_prepare_all
+}