summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-01-27 15:36:11 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-01-27 18:23:50 -0600
commit09e8cb3ff85c06127895195e7bad9ed63516f109 (patch)
tree3254ee581d10a4d6a44ae16832c06b2615122b23 /dev-python/reno
parentdev-python/reno: py37 support (diff)
downloadgentoo-09e8cb3ff85c06127895195e7bad9ed63516f109.tar.gz
gentoo-09e8cb3ff85c06127895195e7bad9ed63516f109.tar.bz2
gentoo-09e8cb3ff85c06127895195e7bad9ed63516f109.zip
dev-python/reno: cleanup
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest2
-rw-r--r--dev-python/reno/reno-2.11.2.ebuild6
-rw-r--r--dev-python/reno/reno-2.2.1.ebuild27
-rw-r--r--dev-python/reno/reno-2.5.0.ebuild26
4 files changed, 3 insertions, 58 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index 8a43cfa3ea7b..60b1aef19246 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1,4 +1,2 @@
DIST reno-2.11.2.tar.gz 74623 BLAKE2B 5c985a81fb6ef7926eadfd1b096f1a1358cb814100b75c6175b6507c2d9ce64f5a06799164a7593cc40f00695cf538c9a49bee1a4d0f78c115519d660681b315 SHA512 b2ef0d9112e327d3a581bfe9b4d6e47b7b4edaa3fe463716772438aab0dcee445d94aaa93bfc7036ead297206353ade73a34d148521ef5d25abe9ca5e655a13f
-DIST reno-2.2.1.tar.gz 56013 BLAKE2B db1966cf542e74e6842be64ee6a1a13cefcedab261bab951c9e39082ab0c0bf278e0b88bf3e876250f141c627a3625fb8038d190a6d58ee8d87054a86da38172 SHA512 278a7a43168f9467342f25c3eb8692e119cac285940b5d3f5a13f8f45acaffde962d2eeac720f2e5d824d085446fe5d660ef7082f95dd3c0360d594de5a65fb1
-DIST reno-2.5.0.tar.gz 62819 BLAKE2B 1446d1289749df74d09c123af69dc6cacedb539b8387c73a1b0f0425651679e1332427afc482ba352e5176a76fcd6bfb65b31f731e0cfb2d137e23b739110b56 SHA512 ee7c44235dd1c3c253b426abbafd490658d642d56ebac5688dd1e3fca45451f26855f421b252c64f9e143bd67c8b08a9e4c6b79edc9c7341b26150a576458570
DIST reno-2.7.0.tar.gz 65269 BLAKE2B f3ba0e33246d40f7f16739f367ad313ce440cd33c6f03de268f2e02293446e0d3a043287c36492d8cae44b65c682c09d13ab0e2c86beffc23a85184ef27a751b SHA512 daf32dd7c08f9f75a9a334db8aa9e8c4fdad266bd5e68a43a87920751cf57549fba7906da26dc6c8f79b97bfaf51ad481f80ce99168cd65cfbd62848cb3d0cab
diff --git a/dev-python/reno/reno-2.11.2.ebuild b/dev-python/reno/reno-2.11.2.ebuild
index 699a74dcfdda..6c2893665fe8 100644
--- a/dev-python/reno/reno-2.11.2.ebuild
+++ b/dev-python/reno/reno-2.11.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
inherit distutils-r1
@@ -12,7 +12,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE=""
CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
diff --git a/dev-python/reno/reno-2.2.1.ebuild b/dev-python/reno/reno-2.2.1.ebuild
deleted file mode 100644
index ffde3f5bd9ff..000000000000
--- a/dev-python/reno/reno-2.2.1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
-HOMEPAGE="https://pypi.org/project/reno/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"
diff --git a/dev-python/reno/reno-2.5.0.ebuild b/dev-python/reno/reno-2.5.0.ebuild
deleted file mode 100644
index edb09f9a72d3..000000000000
--- a/dev-python/reno/reno-2.5.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
-HOMEPAGE="https://pypi.org/project/reno/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-1.4[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]"