summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-03 08:03:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-03 10:52:19 +0200
commit39fe06a54912583ebeec29c26b23df470b890341 (patch)
tree3baf0599636e03c23a57397383984e4fe8a29c34 /dev-python/reno
parentdev-python/cfn-python-lint: Bump to 0.53.0 (diff)
downloadgentoo-39fe06a54912583ebeec29c26b23df470b890341.tar.gz
gentoo-39fe06a54912583ebeec29c26b23df470b890341.tar.bz2
gentoo-39fe06a54912583ebeec29c26b23df470b890341.zip
dev-python/reno: Bump to 3.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reno')
-rw-r--r--dev-python/reno/Manifest1
-rw-r--r--dev-python/reno/reno-3.4.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/reno/Manifest b/dev-python/reno/Manifest
index dfeee76f99d7..5619cdb5d784 100644
--- a/dev-python/reno/Manifest
+++ b/dev-python/reno/Manifest
@@ -1 +1,2 @@
DIST reno-3.3.0.tar.gz 81168 BLAKE2B 46afacfa437c9d5fed49d454edaf92b96ffbd677de02d91c7fd431b5ae98764918e099dd486345907446a19b2c94a1c36ac5cff9cf6d911438b48d41d9585ba1 SHA512 0fb6ff09e71b829cabe452693aac0c3a14d44f75f93e8934ebd0b0861e7dcd749a92b7bf19bc4f46202ecb02840edd6d5e5787c8b8a5b64a6b91fb52fe18287d
+DIST reno-3.4.0.tar.gz 82815 BLAKE2B aab374c48c1dcf25ba7a78d46069c5d659762bf01d25dc05f597f02098ee10e7b8c518a0afad186ecd93602782a7c50294183b7e33075f8bfe57cc0bc3c1d016 SHA512 cbfd5d9b41beb1599438e249b8082175c8bd2b8dca62d8e6fd1ef742bf889adf6490e1ed0fa78d8aca663a0fb6bbe70742815a6512c6d51fb8073745b6860d65
diff --git a/dev-python/reno/reno-3.4.0.ebuild b/dev-python/reno/reno-3.4.0.ebuild
new file mode 100644
index 000000000000..755626baf35b
--- /dev/null
+++ b/dev-python/reno/reno-3.4.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Release notes manager, storing release notes in a git repo and building docs"
+HOMEPAGE="https://pypi.org/project/reno/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~x86"
+
+RDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.3.1[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.15.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.11[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-2.1.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ )
+"
+
+# The doc needs to be built from a git repository
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ # Some tests need to be run from a git repository
+ rm reno/tests/test_{cache,semver}.py || die
+ distutils-r1_python_prepare_all
+}