summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/reportlab/reportlab-2.6.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/reportlab/reportlab-2.6.ebuild')
-rw-r--r--dev-python/reportlab/reportlab-2.6.ebuild81
1 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/reportlab/reportlab-2.6.ebuild b/dev-python/reportlab/reportlab-2.6.ebuild
new file mode 100644
index 000000000000..ec9f45060f7b
--- /dev/null
+++ b/dev-python/reportlab/reportlab-2.6.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+# Tests crash with pypy
+
+inherit distutils-r1 eutils flag-o-matic prefix
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="http://www.reportlab.com/ http://pypi.python.org/pypi/reportlab"
+SRC_URI="http://www.reportlab.com/ftp/${P}.tar.gz
+ http://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="virtual/python-imaging
+ media-fonts/ttf-bitstream-vera
+ media-libs/libart_lgpl
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ sed -i \
+ -e 's|/usr/lib/X11/fonts/TrueType/|/usr/share/fonts/ttf-bitstream-vera/|' \
+ -e 's|/usr/local/Acrobat|/opt/Acrobat|g' \
+ -e 's|%(HOME)s/fonts|%(HOME)s/.fonts|g' \
+ src/reportlab/rl_config.py || die "sed failed"
+
+ epatch "${FILESDIR}/${PN}-2.2_qa_msg.patch"
+
+ rm -fr src/rl_addons/renderPM/libart_lgpl
+ epatch "${FILESDIR}/${PN}-2.4-external_libart_lgpl.patch"
+
+ eprefixify setup.py
+
+ epatch "${FILESDIR}/${PN}-2.5-pypy-implicit-PyArg_NoArgs.patch"
+}
+
+src_compile() {
+ append-cflags -fno-strict-aliasing
+ distutils-r1_src_compile
+}
+
+python_compile_all() {
+ if use doc; then
+ cd docs || die
+ "${PYTHON}" genAll.py || die "docs generation failed"
+ fi
+}
+
+python_test() {
+ pushd tests > /dev/null || die
+ "${PYTHON}" runAll.py || die "Testing failed with ${EPYTHON}"
+ popd > /dev/null || die
+}
+
+python_install_all() {
+ use doc && dodoc docs/*.pdf
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos
+ insinto /usr/share/doc/${PF}/tools/pythonpoint
+ doins -r tools/pythonpoint/demos
+ fi
+ distutils-r1_python_install_all
+}