summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-14 08:51:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-14 09:18:58 +0200
commit1905e4a32e05cf411265e3cb46aa44c6768da17c (patch)
tree5bbd50acc25141eda63384fd43d9a840a9604fe1 /dev-python/reportlab
parentdev-python/duecredit: Bump to 0.9.1 (diff)
downloadgentoo-1905e4a32e05cf411265e3cb46aa44c6768da17c.tar.gz
gentoo-1905e4a32e05cf411265e3cb46aa44c6768da17c.tar.bz2
gentoo-1905e4a32e05cf411265e3cb46aa44c6768da17c.zip
dev-python/reportlab: Bump to 3.5.67
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/reportlab')
-rw-r--r--dev-python/reportlab/Manifest1
-rw-r--r--dev-python/reportlab/reportlab-3.5.67.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/reportlab/Manifest b/dev-python/reportlab/Manifest
index 1cfe133aefeb..edc0b02a62cd 100644
--- a/dev-python/reportlab/Manifest
+++ b/dev-python/reportlab/Manifest
@@ -4,3 +4,4 @@ DIST reportlab-3.5.63.tar.gz 2908785 BLAKE2B 0af6f72063e4a1f4464bf8d847575e23b5d
DIST reportlab-3.5.64.tar.gz 2909252 BLAKE2B 5922ec3083238c2884d7ebede5593a15fa537a8bd72f5cf9b6a84bf1673fe43be2df9f2125f033400c766fdf78a07f4c919b331bbd2215acb950dbbcb971bced SHA512 ac4eb9a7c337ebdde81dcfa9e6b9609aec7fca8451d383c28b9d58e0ea73bd71c328fb2362ba5805b96e10c95dc166d5806eb763c5c325a6d72a9474dce3c422
DIST reportlab-3.5.65.tar.gz 2909468 BLAKE2B cec88aa00299d329a44379798824a8694f7547a9bb35685b202873387d0b40cdb2bfc864257ee2749c8cc24ed1d26e1ef22c1059fe2e27df38cedae71d55ceda SHA512 a143ff277ab4e9bf667d8334aca9d5b0c959b64eebbd5eda8d6fed95b09cd28544a33bbe5f630753f167b54e63a1a5e04f841c8892712e93d2f8739e9651269a
DIST reportlab-3.5.66.tar.gz 2911372 BLAKE2B 58bc718157066a82eece18141e08547b8360dd653d2365fdbe1708fee2f1f8dffeced60500b4e866c31947fae00b78ab9853983563fb89e5b34827173c71a534 SHA512 81fac9fd751a451bd5bf6c91efcf9e250ec1c028587c9ed76129d7fd20c4efa17ea0ae45f08dd43a33adf6f4a2c5338a557e869b85d0b6405626720b0e9221a8
+DIST reportlab-3.5.67.tar.gz 2911726 BLAKE2B 8dbd3bb54c2c651616c3b6be905ac7b43b3a8f30f630d2f9b91882416cb4513751affa507870fdd801b5aa53480498ecc9a5fe3902ab38d72288b6f48ce892e9 SHA512 5a0ec58f0ee925079f3756bac309bd5aaf159118a4ed7ec6467721ead23e5db37839014bb49f1804a0dee4532ce21f9c78adec99ec61a4aeffd957184d489a6c
diff --git a/dev-python/reportlab/reportlab-3.5.67.ebuild b/dev-python/reportlab/reportlab-3.5.67.ebuild
new file mode 100644
index 000000000000..71dd8dad099d
--- /dev/null
+++ b/dev-python/reportlab/reportlab-3.5.67.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="Tools for generating printable PDF documents from any data source"
+HOMEPAGE="
+ https://www.reportlab.com/
+ https://pypi.org/project/reportlab/"
+SRC_URI="
+ mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz
+ https://www.reportlab.com/ftp/fonts/pfbfer-20070710.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/libart_lgpl
+ sys-libs/zlib:="
+RDEPEND="
+ ${DEPEND}
+ dev-python/pillow[tiff,truetype,jpeg(+),${PYTHON_USEDEP}]"
+BDEPEND="
+ app-arch/unzip"
+
+distutils_enable_sphinx docs/source
+distutils_enable_tests unittest
+
+PATCHES=(
+ # bug 738312, remove -L/usr/lib from link line
+ "${FILESDIR}"/${PN}-3.5.48-usr-lib-LLD.patch
+)
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${P}/src/reportlab/fonts || die
+ unpack pfbfer-20070710.zip
+}
+
+python_prepare_all() {
+ # tests requiring Internet access
+ sed -i -e 's:test0:_&:' \
+ tests/test_platypus_general.py \
+ tests/test_platypus_images.py || die
+ sed -i -e 's:test9:_&:' tests/test_lib_utils.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+src_configure() {
+ mydistutilsargs=(
+ --no-download-t1-files
+ --use-system-libart
+ )
+}
+
+python_test() {
+ pushd tests >/dev/null || die
+ "${EPYTHON}" runAll.py -v || die "Testing failed with ${EPYTHON}"
+ popd >/dev/null || die
+}