summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 09:28:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-26 10:41:28 +0100
commitb6a36dec7e7fba63d34b5a71b9fbf78afa2addd3 (patch)
tree167ae0c758c3b01d80ed6e3ed71f08bde332615e /dev-python/requests
parentdev-python/click: Remove old (diff)
downloadgentoo-b6a36dec7e7fba63d34b5a71b9fbf78afa2addd3.tar.gz
gentoo-b6a36dec7e7fba63d34b5a71b9fbf78afa2addd3.tar.bz2
gentoo-b6a36dec7e7fba63d34b5a71b9fbf78afa2addd3.zip
dev-python/requests: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/requests')
-rw-r--r--dev-python/requests/Manifest2
-rw-r--r--dev-python/requests/requests-2.24.0-r1.ebuild56
-rw-r--r--dev-python/requests/requests-2.25.0.ebuild56
3 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/requests/Manifest b/dev-python/requests/Manifest
index 4123a69f944b..c3b2f9c1b313 100644
--- a/dev-python/requests/Manifest
+++ b/dev-python/requests/Manifest
@@ -1,3 +1 @@
-DIST requests-2.24.0.tar.gz 115071 BLAKE2B ae98be1d023b2a7b883e15a7a5d214ecbf482234e9de6bfc9cd06d1f04d1b57d101d41a2c6fdd07b7a6b468875463514841d2e023391ac8ae0797a2cb58b3424 SHA512 46ca8ab70eb39be8398c242404b9b3ffb6baddd5c78eaad125b55c719154eb8c7b6a737a8dc587b0cb51b3b9a074abaa8b2ff347a64d38f4f90cdba4db16a119
-DIST requests-2.25.0.tar.gz 101897 BLAKE2B 5de8f4f5059915f929ebb71d8209bfefbe95bb381544ed0b6875cc01cb958e6fe8861cd8321143463da5dd872ad4ff8c828008bcd6409b41857c4d2037db3f67 SHA512 dd13ccb6bcd95bdd31a414dba67e5a0914ff172ae6f5d255849837e8e2a7e404e3c02fc3d07e5ff6dc81c12d0fe56c3b83bc62bc377dd3f504b00b97b144db74
DIST requests-2.25.1.tar.gz 102161 BLAKE2B 1901ca3bb1eb7a6eb7689a81e01c1c23d3f359835507fda78de734162cbd8573b7640c9376cb50ed9397603d67d9a14624028573c2709086547f37993a959429 SHA512 ca6b0a257b448a999cade0ae173c29cddc9cfffb319d16fc3d051d3e1cd77161536e3cab279b3cba59c60d29d7864a9281c1fa1f689ce48d3bce2ca9f1cd8d45
diff --git a/dev-python/requests/requests-2.24.0-r1.ebuild b/dev-python/requests/requests-2.24.0-r1.ebuild
deleted file mode 100644
index 4396bfd81596..000000000000
--- a/dev-python/requests/requests-2.24.0-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="https://requests.readthedocs.io/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="socks5 +ssl"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- <dev-python/chardet-4[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-3[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.26[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- )
-"
-
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # strip tests that require some kind of network
- sed -e 's:test_connect_timeout:_&:' \
- -e 's:test_total_timeout_connect:_&:' \
- -i tests/test_requests.py || die
- # probably pyopenssl version dependent
- sed -e 's:test_https_warnings:_&:' \
- -i tests/test_requests.py || die
- # doctests rely on networking
- sed -e 's:--doctest-modules::' \
- -i pytest.ini || die
-}
diff --git a/dev-python/requests/requests-2.25.0.ebuild b/dev-python/requests/requests-2.25.0.ebuild
deleted file mode 100644
index 32f9631e5fb7..000000000000
--- a/dev-python/requests/requests-2.25.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="HTTP library for human beings"
-HOMEPAGE="https://requests.readthedocs.io/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
-IUSE="socks5 +ssl"
-
-RDEPEND="
- >=dev-python/certifi-2017.4.17[${PYTHON_USEDEP}]
- >=dev-python/chardet-3.0.2[${PYTHON_USEDEP}]
- <dev-python/chardet-4[${PYTHON_USEDEP}]
- >=dev-python/idna-2.5[${PYTHON_USEDEP}]
- <dev-python/idna-3[${PYTHON_USEDEP}]
- <dev-python/urllib3-1.27[${PYTHON_USEDEP}]
- socks5? ( >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}] )
- ssl? (
- >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
- )
-"
-
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # strip tests that require some kind of network
- sed -e 's:test_connect_timeout:_&:' \
- -e 's:test_total_timeout_connect:_&:' \
- -i tests/test_requests.py || die
- # probably pyopenssl version dependent
- sed -e 's:test_https_warnings:_&:' \
- -i tests/test_requests.py || die
- # doctests rely on networking
- sed -e 's:--doctest-modules::' \
- -i pytest.ini || die
-}