summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:33:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 18:39:15 -0500
commite8b42125f2e61da55af02596e1bdaf3b5a9762a1 (patch)
tree2f9eaa34da6c3d2b78b5574573037f5c293c213b /dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
parentsci-geosciences/googleearth: Regenerate Manifest file. (diff)
downloadgentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.tar.gz
gentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.tar.bz2
gentoo-e8b42125f2e61da55af02596e1bdaf3b5a9762a1.zip
dev-python/requestsexceptions: adding for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild')
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
new file mode 100644
index 000000000000..699e009aed55
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.1.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"