summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2021-06-15 10:08:22 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2021-06-15 10:16:35 -0500
commit957d5a78a50d846f992272a06592c355b6f66adc (patch)
treef2b3c6cf6d857cd235d666f2b581cdc0c75dc4e0 /dev-python/resolvelib/resolvelib-0.6.0.ebuild
parentprofiles: [QA] mask broken sys-apps/fwupd-1.6.x bump (diff)
downloadgentoo-957d5a78a50d846f992272a06592c355b6f66adc.tar.gz
gentoo-957d5a78a50d846f992272a06592c355b6f66adc.tar.bz2
gentoo-957d5a78a50d846f992272a06592c355b6f66adc.zip
dev-python/resolvelib: 0.6.0 added for ansible
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/resolvelib/resolvelib-0.6.0.ebuild')
-rw-r--r--dev-python/resolvelib/resolvelib-0.6.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/resolvelib/resolvelib-0.6.0.ebuild b/dev-python/resolvelib/resolvelib-0.6.0.ebuild
new file mode 100644
index 000000000000..2535428a3c16
--- /dev/null
+++ b/dev-python/resolvelib/resolvelib-0.6.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_7 python3_8 python3_9 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="provides a Resolver class that includes dependency resolution logic"
+HOMEPAGE="https://github.com/sarugaku/resolvelib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""