summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-05 16:15:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-05 16:24:11 +0200
commit8be9f4fed9fb931b9ca71eb586bd4f4809c8072a (patch)
tree5fa8416e5528815037d38a4a90d10db3e7e77fa4 /dev-python/rfc3987
parentsys-boot/grub: Install an example grub.cfg (diff)
downloadgentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.tar.gz
gentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.tar.bz2
gentoo-8be9f4fed9fb931b9ca71eb586bd4f4809c8072a.zip
dev-python/rfc3987: bump to 1.3.7
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/rfc3987')
-rw-r--r--dev-python/rfc3987/Manifest1
-rw-r--r--dev-python/rfc3987/rfc3987-1.3.7.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rfc3987/Manifest b/dev-python/rfc3987/Manifest
index a87f00a3ba1d..b3fb1cef1916 100644
--- a/dev-python/rfc3987/Manifest
+++ b/dev-python/rfc3987/Manifest
@@ -1 +1,2 @@
DIST rfc3987-1.3.6.tar.gz 8434 SHA256 599801156e35b5054138585c92ab4d1b729b0f2feeb961b65347116764df4aa7 SHA512 f89eeede3da28f39950afd8a9db9bfb46a08b13925709c1026941571463c3885696d18bf96cc45819a13e2c91c9b7b8f00bee864fa2a52f5d1671dab28ce19e1 WHIRLPOOL 715efdbac226b7932978f7593c439015d5a1d88d0c728f8087bc3b9789031e2f82977e8c291317eeb705d404a4d8942b0028daf01c00fbe35e912001debd05fd
+DIST rfc3987-1.3.7.tar.gz 20701 SHA256 91a7826b0a26c246a5a91bef09c2c0809c713a689be689b9571e78a13f6557a4 SHA512 c5fa8eb36358f7f42d12adc305031bfff7bd77e83316ad4458ed07acc6094c7d9109b95848b9296dcbc6677ce34aa59b1be8fd57dfcdc6be47eb92aeda51c518 WHIRLPOOL 5c4051d3192edb8124e0350c9cd489f74ec88929f1447c533a5ba6f3105fa937b9b789776a43e762ae4373a83cf92a114bd7f54d970bda2fe72b3ed61c724c1a
diff --git a/dev-python/rfc3987/rfc3987-1.3.7.ebuild b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
new file mode 100644
index 000000000000..75bdda89b090
--- /dev/null
+++ b/dev-python/rfc3987/rfc3987-1.3.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 http://pypi.python.org/pypi/rfc3987"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-python/regex[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}