summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-02-14 20:09:04 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-02-14 20:09:04 +0100
commitbaec20c97b63990e9be917d372324cfe68f7b700 (patch)
treeeda2b3d524195a5a86f5061e5bbb2c7ed9cda1e2 /dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild
parentdev-python/backports-lzma: Version bump to 0.0.8 (diff)
downloadgentoo-baec20c97b63990e9be917d372324cfe68f7b700.tar.gz
gentoo-baec20c97b63990e9be917d372324cfe68f7b700.tar.bz2
gentoo-baec20c97b63990e9be917d372324cfe68f7b700.zip
dev-python/robotframework-sshlibrary: Version bump to 2.1.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild')
-rw-r--r--dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild b/dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild
new file mode 100644
index 000000000000..5c9c71a0bb49
--- /dev/null
+++ b/dev-python/robotframework-sshlibrary/robotframework-sshlibrary-2.1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A test library for Robot Framework that enables SSH and SFTP"
+HOMEPAGE="https://github.com/robotframework/SSHLibrary https://pypi.python.org/pypi/robotframework-sshlibrary/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-python/paramiko-1.8.0[${PYTHON_USEDEP}]
+ dev-python/robotframework[${PYTHON_USEDEP}]"