summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:46:02 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-29 21:52:59 +0300
commit482e93790a4a0545091791bc9d8fa82f2831f992 (patch)
treea1b84cf318484d38fec9b8e4d3c741cd37ab3a94 /dev-python/roman
parentdev-python/recommonmark: enable py3.11 (diff)
downloadgentoo-482e93790a4a0545091791bc9d8fa82f2831f992.tar.gz
gentoo-482e93790a4a0545091791bc9d8fa82f2831f992.tar.bz2
gentoo-482e93790a4a0545091791bc9d8fa82f2831f992.zip
dev-python/roman: EAPI=8, Use PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/roman')
-rw-r--r--dev-python/roman/roman-3.3-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/roman/roman-3.3-r1.ebuild b/dev-python/roman/roman-3.3-r1.ebuild
new file mode 100644
index 000000000000..95db3de3f2d5
--- /dev/null
+++ b/dev-python/roman/roman-3.3-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="An Integer to Roman numerals converter"
+HOMEPAGE="https://pypi.org/project/roman/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py
+
+python_prepare_all() {
+ mv "${S}/src/tests.py" . || die "moving test file failed"
+ distutils-r1_python_prepare_all
+}