summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-03-04 14:40:39 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-03-04 15:20:37 +0100
commit1d8018bc9433c6e2c7550c0d17c3c6beeeb2ad8a (patch)
tree3569660c5ac2087bf394df4805a30d49ab0dce32 /dev-python/rosdistro
parentdev-python/rosdistro: Remove old (diff)
downloadgentoo-1d8018bc9433c6e2c7550c0d17c3c6beeeb2ad8a.tar.gz
gentoo-1d8018bc9433c6e2c7550c0d17c3c6beeeb2ad8a.tar.bz2
gentoo-1d8018bc9433c6e2c7550c0d17c3c6beeeb2ad8a.zip
dev-python/rosdistro: bump to 0.6.8
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/rosdistro')
-rw-r--r--dev-python/rosdistro/Manifest1
-rw-r--r--dev-python/rosdistro/rosdistro-0.6.8.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rosdistro/Manifest b/dev-python/rosdistro/Manifest
index 7a181b46c743..3c7a2f19bedc 100644
--- a/dev-python/rosdistro/Manifest
+++ b/dev-python/rosdistro/Manifest
@@ -1 +1,2 @@
DIST rosdistro-0.6.6.tar.gz 58881 BLAKE2B 9daa5c08b97509606d5077f55e8a85d2cd278f69aebff22feefd9661d455f38cff549ee26f894b040cad7192f044828a20cf749d83a257a8b5604f07d382f081 SHA512 2a4b0dfcaa43a8e4d4a0fff5ed204ad81317156128d9050e0c67dfe2cd9efda2bfc84f454e424ebd457e7c62c7c6add113ceb31e99310c34a9fc9f206e510922
+DIST rosdistro-0.6.8.tar.gz 59771 BLAKE2B 5610ef992824104570abc8c5cc0224838ee1442d942f8f317b20b300831f7536649b47360e7f542e484d75eac29af71ce9e82fadf91b540f4671478039776921 SHA512 57db65b7cba29e41c14ea4e45f951a410e6152ce4247afd1b15df51cd79e50bdbc95151eac02acc666f8bc3c2658695600ad1b4fc0f4152d71901685c9e8f558
diff --git a/dev-python/rosdistro/rosdistro-0.6.8.ebuild b/dev-python/rosdistro/rosdistro-0.6.8.ebuild
new file mode 100644
index 000000000000..8780e241c60c
--- /dev/null
+++ b/dev-python/rosdistro/rosdistro-0.6.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rosdistro"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Tools to work with catkinized rosdistro files"
+HOMEPAGE="http://wiki.ros.org/rosdistro"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ros-infrastructure/rosdistro/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="
+ dev-python/catkin_pkg[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ nosetests --with-xunit test || die
+}