summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-17 15:07:58 +0200
commit03a89df55a0073d62659a16f1a18c6da50708d61 (patch)
treeef5358a043ce1b5ed81ecdef236afdf347886548 /dev-python/rospkg/rospkg-9999.ebuild
parentdev-python/rosdistro: eapi update and bump to 0.6.9 (diff)
downloadgentoo-03a89df55a0073d62659a16f1a18c6da50708d61.tar.gz
gentoo-03a89df55a0073d62659a16f1a18c6da50708d61.tar.bz2
gentoo-03a89df55a0073d62659a16f1a18c6da50708d61.zip
dev-python/rospkg: eapi update and bump to 1.1.7
Package-Manager: Portage-2.3.46, Repoman-2.3.10
Diffstat (limited to 'dev-python/rospkg/rospkg-9999.ebuild')
-rw-r--r--dev-python/rospkg/rospkg-9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/rospkg/rospkg-9999.ebuild b/dev-python/rospkg/rospkg-9999.ebuild
index bf7619313e02..c59845d0d461 100644
--- a/dev-python/rospkg/rospkg-9999.ebuild
+++ b/dev-python/rospkg/rospkg-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
SCM=""
@@ -30,10 +30,13 @@ SLOT="0"
IUSE="test"
RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND} ${BDEPEND}
+ test? (
dev-python/coverage[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)