summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-03 13:48:57 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 13:54:04 +0100
commitb1694af36853b4baf9342bfd5c87df1e26beac3b (patch)
treec0a3af05553afed89bb330177c69201284ffba16 /dev-python/rpy
parentdev-python/rpyc: Remove old (diff)
downloadgentoo-b1694af36853b4baf9342bfd5c87df1e26beac3b.tar.gz
gentoo-b1694af36853b4baf9342bfd5c87df1e26beac3b.tar.bz2
gentoo-b1694af36853b4baf9342bfd5c87df1e26beac3b.zip
dev-python/rpy: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rpy')
-rw-r--r--dev-python/rpy/Manifest1
-rw-r--r--dev-python/rpy/rpy-2.9.0.ebuild47
2 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/rpy/Manifest b/dev-python/rpy/Manifest
index 2f9e4ebd9bb3..ccb5384eeb5c 100644
--- a/dev-python/rpy/Manifest
+++ b/dev-python/rpy/Manifest
@@ -1,2 +1 @@
-DIST rpy2-2.9.0.tar.gz 193062 BLAKE2B 92492821856e516f8f620397cba2e0ffb17718156c7c3a0bc8df8e744f0adf1ea6006e5c762ba99aa142fe06d327a240bf5d616175e81a80d28a21265c9771aa SHA512 55be876fb7316a08f507f3a332ed29d71b52f733c1986482f141e694d66d0e01a51a9c3f0260f6fe0086d7bfbc1f58b678cda4570665e4f1ffdb120c793ef1b2
DIST rpy2-3.4.2.tar.gz 186064 BLAKE2B 5c800f546240cc33e6341973adae813edcdaa88e90ea0274e97075bc4516ced20828ccc6010ae23aead0b227639158240dae9b678790e0d28f974f10e9ac0e5f SHA512 e754d082bf392de582829bc078b512a071d0c0aa79ce3ed3692ad88b3816863b520a4ef9bbeaccbb2a7284685e470f345ba103e3db78a1c95187c0b554565314
diff --git a/dev-python/rpy/rpy-2.9.0.ebuild b/dev-python/rpy/rpy-2.9.0.ebuild
deleted file mode 100644
index e85f0ecf2573..000000000000
--- a/dev-python/rpy/rpy-2.9.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_7 )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1 flag-o-matic virtualx
-
-MYSLOT=2
-MY_PN=${PN}${MYSLOT}
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python interface to the R Programming Language"
-HOMEPAGE="https://rpy.sourceforge.net/
- https://pypi.org/project/rpy2/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="AGPL-3 GPL-2 LGPL-2.1 MPL-1.1"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# ggplot2 is a test dep but not in portage
-RESTRICT="test"
-
-RDEPEND="
- >=dev-lang/R-3.2
- dev-python/numpy[${PYTHON_USEDEP}]
- >=dev-python/pandas-0.13.1[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- test? ( >=dev-lang/R-3.2[X,png] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-python_compile() {
- distutils-r1_python_compile
-}
-
-python_test() {
- cd "${BUILD_DIR}"/lib || die
- virtx "${EPYTHON}" -m 'rpy2.tests'
-}