summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-02 20:22:51 +0000
committerSam James <sam@gentoo.org>2020-08-02 20:22:51 +0000
commitc246db6e9dc064e25e2f4dec44bd3af18dcd6062 (patch)
tree16f72d2f746c6bfaaa219406b42542055075133f /dev-python/rq
parentdev-python/redis-py: bump to 3.5.3 (diff)
downloadgentoo-c246db6e9dc064e25e2f4dec44bd3af18dcd6062.tar.gz
gentoo-c246db6e9dc064e25e2f4dec44bd3af18dcd6062.tar.bz2
gentoo-c246db6e9dc064e25e2f4dec44bd3af18dcd6062.zip
dev-python/rq: bump to 1.5.0
* Run tests * Use Github tarball to have tests * Drop ppc{,64} keyword temporarily for new test dep (dev-python/sentry-sdk) * Tighten dev-python/redis-py dependency Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/rq')
-rw-r--r--dev-python/rq/Manifest1
-rw-r--r--dev-python/rq/rq-1.5.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/rq/Manifest b/dev-python/rq/Manifest
index f6fb3743c42e..165747160d90 100644
--- a/dev-python/rq/Manifest
+++ b/dev-python/rq/Manifest
@@ -1,2 +1,3 @@
DIST rq-1.3.0.tar.gz 50906 BLAKE2B 073ef65c90b2f4cab7505148133cf9e8652f6915bcb34d96b61fca2eb3096d5eb8fb506dfa3d22f402d4ef7ff8e5456faa3bdf7ad6586cfa563b7b2c2da8cb95 SHA512 3c7c3b63a7068ada14c39fa21631fa35d336955c8f5b7b5fbf3d75a99b046abacc2ff28a3a58fc03d587be8bf8e22eea33d31142d3be880afc49287a004ff782
DIST rq-1.4.3.tar.gz 52258 BLAKE2B fd2bb19239ac3011005b34cf041e7736794a27b2097a7ff1808a716d45ad224ad349e316f172308175174f59ff0d3d2bbe0c6778bd66cdad6755da2740898c0d SHA512 177c748148a109efaeddf14b3847e7980882f385ba0e346ccfa72983d584f1c739417383c6eec83370a66f1ceeb5f955de9d5ccf87e4136074aa52e2f9144bd3
+DIST rq-1.5.0.tar.gz 569320 BLAKE2B 5349f6e806c5348e584513bf8fe8828c44909b8f4e53fcdfe40e0c617f162859dbc89d4595993c29227a25cef5b6ddbb758c51c3e50b442ada62eaca0585490a SHA512 87eb83de529afe3a1e0a9f2b1727aba97482e3e55024aede29ad6e12ed5b92ca147bef8d720a09b34939c04ac5e37642147aea5b1b7686ed4b2aaacdcf998f6d
diff --git a/dev-python/rq/rq-1.5.0.ebuild b/dev-python/rq/rq-1.5.0.ebuild
new file mode 100644
index 000000000000..a731f4cecab4
--- /dev/null
+++ b/dev-python/rq/rq-1.5.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="simple, lightweight library for creating and processing background jobs"
+HOMEPAGE="https://python-rq.org https://github.com/rq/rq"
+SRC_URI="https://github.com/rq/rq/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? ( dev-python/sentry-sdk[${PYTHON_USEDEP}] )
+"
+DEPEND="
+ >=dev-python/click-5.0[${PYTHON_USEDEP}]
+ >=dev-python/redis-py-3.5.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.5.0-no-install-tests.patch"
+)
+
+src_test() {
+ local redis_pid="${T}"/redis.pid
+ local redis_port=6379
+ local redis_test_config="daemonize yes
+ pidfile ${redis_pid}
+ port ${redis_port}
+ bind 127.0.0.1
+ "
+
+ # Spawn Redis itself for testing purposes
+ # NOTE: On sam@'s machine, spawning Redis can hang in the sandbox.
+ # I'm not restricting tests yet because this doesn't happen for anyone else AFAICT.
+ elog "Spawning Redis"
+ elog "NOTE: Port ${redis_port} must be free"
+ /usr/sbin/redis-server - <<< "${redis_test_config}" || die
+
+ # Run the actual tests
+ distutils-r1_src_test
+
+ # Clean up afterwards
+ kill "$(<"${redis_pid}")" || die
+}
+
+python_test() {
+ # Tests needing rqworker:
+ # TestWorkerSubprocess::test_run_access_self, test_run_empty_queue, test_run_scheduled_access_self
+ distutils_install_for_testing
+ PATH="${BUILD_DIR}/test/scripts/:${PATH}" pytest -vv || die "Testsuite failed under ${EPYTHON}"
+}