summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-16 01:13:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-16 01:32:24 +0100
commit3485bf7b99e595033c3acc6b76fe4c7a70e19525 (patch)
tree29ca0d10027f57d2709eada3ae01a492dbd60372 /dev-python/rsa
parentkde-frameworks/kdnssd: Drop 5.79.0 (diff)
downloadgentoo-3485bf7b99e595033c3acc6b76fe4c7a70e19525.tar.gz
gentoo-3485bf7b99e595033c3acc6b76fe4c7a70e19525.tar.bz2
gentoo-3485bf7b99e595033c3acc6b76fe4c7a70e19525.zip
dev-python/rsa: Bump to 4.7.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rsa')
-rw-r--r--dev-python/rsa/Manifest1
-rw-r--r--dev-python/rsa/rsa-4.7.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rsa/Manifest b/dev-python/rsa/Manifest
index 2e39bd35d952..cd9c4a74b8df 100644
--- a/dev-python/rsa/Manifest
+++ b/dev-python/rsa/Manifest
@@ -1 +1,2 @@
+DIST python-rsa-version-4.7.1.gh.tar.gz 65085 BLAKE2B e63200a7861f13177d042ae92dbb9f8eb4ba3c30174e21b12cb4d84d9a39d3cbb59d6dacec5d4e3d2375ca100bf48c12dabff3f90011f3a3c795ece9e863893f SHA512 f06eee5d6e72c11cdf68ee756ffef7fd9d002ee93939158593ee6d0b5cf1abbfad31c50f6cfd4676d9f64247faee6019d8b214d22324706c82d07068f55ebd94
DIST python-rsa-version-4.7.gh.tar.gz 64870 BLAKE2B 1e8c8c1a2c4261fdfacf5c83a76b0828dd2fabd26c0a76c0d39e7043a3005058e74a50c1d8f6ed705f5a47ab5d7c077587061ff097cad87424a2e82a8b478b3f SHA512 a88c8f04860e8babe762eb70e6096c55fbb4bbde43525564ecc719f5e6c56fdb65fa7b82a907c6de529a8effea26b1f6f8ffa3440dab99bff97664f7ce5fe31a
diff --git a/dev-python/rsa/rsa-4.7.1.ebuild b/dev-python/rsa/rsa-4.7.1.ebuild
new file mode 100644
index 000000000000..32aff8b85fb7
--- /dev/null
+++ b/dev-python/rsa/rsa-4.7.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P=python-rsa-version-${PV}
+DESCRIPTION="Pure-Python RSA implementation"
+HOMEPAGE="
+ https://stuvel.eu/rsa/
+ https://pypi.org/project/rsa/"
+SRC_URI="
+ https://github.com/sybrenstuvel/python-rsa/archive/version-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyasn1-0.1.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ rm tests/test_mypy.py || die
+ distutils-r1_src_prepare
+}