summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:35 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-22 09:08:35 +0200
commit58f516c214a7ccf0aa24891cf659d90ba13954a4 (patch)
tree043eff11777687196af0db5e5cbe97bf8855b742 /dev-python/rst-linker
parentdev-python/rsa: Remove redundant versions (diff)
downloadgentoo-58f516c214a7ccf0aa24891cf659d90ba13954a4.tar.gz
gentoo-58f516c214a7ccf0aa24891cf659d90ba13954a4.tar.bz2
gentoo-58f516c214a7ccf0aa24891cf659d90ba13954a4.zip
dev-python/rst-linker: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rst-linker')
-rw-r--r--dev-python/rst-linker/Manifest1
-rw-r--r--dev-python/rst-linker/rst-linker-1.11.ebuild55
2 files changed, 0 insertions, 56 deletions
diff --git a/dev-python/rst-linker/Manifest b/dev-python/rst-linker/Manifest
index 32afb6ce3a74..bce775091e28 100644
--- a/dev-python/rst-linker/Manifest
+++ b/dev-python/rst-linker/Manifest
@@ -1,2 +1 @@
-DIST rst.linker-1.11.tar.gz 12569 BLAKE2B 5418f651322c28d8aff2dc735f8ff72325e895d8f2c12dae4985112112f74023c6103e344f4422e944b32b692713834ae5239bc4193edc76bfa85d9e0a674f4a SHA512 8e748330f60e2e1f859fa3ec3fad706d7bbafc78a402b0df242bda7caff1fad3f1b17873fa9ee749d3d214e094f24a35695c627cf9a8d8f08ca99ee6ad0e4e6d
DIST rst.linker-2.0.0.tar.gz 12861 BLAKE2B f52ddab3c8119f0bac64e294e4a5a3cc50916f19f49ca1ca4983d8b5d2bb5401c6accb5873df38609386e12fcd1cb02b867f3633edd4d10606a98936e96e62eb SHA512 ea9fa95de66c95dc384c888446512be66b180d0d76e99fe7a6b8f8348436d4be959d3d567fa521d9fc925b537467a4fdf05f9e9d17f7a6df4aafd6dfd323e4fc
diff --git a/dev-python/rst-linker/rst-linker-1.11.ebuild b/dev-python/rst-linker/rst-linker-1.11.ebuild
deleted file mode 100644
index 13ae3af9cb82..000000000000
--- a/dev-python/rst-linker/rst-linker-1.11.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
-inherit distutils-r1
-
-MY_PN="${PN/-/.}"
-DESCRIPTION="Sphinx plugin to add links and timestamps to the changelog"
-HOMEPAGE="https://github.com/jaraco/rst.linker"
-SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
- doc? (
- >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- )
- test? (
- ${RDEPEND}
- dev-python/path-py[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
- )
-"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs docs/_build/html || die
- HTML_DOCS=( docs/_build/html/. )
- fi
-}
-
-python_test() {
- # Ignore the module from ${S}, use the one from ${BUILD_DIR}
- # Otherwise, ImportMismatchError may occur
- # https://github.com/gentoo/gentoo/pull/1622#issuecomment-224482396
- # Override pytest options to skip flake8
- py.test -v --ignore=rst --override-ini="addopts=--doctest-modules" \
- || die "tests failed with ${EPYTHON}"
-}