summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-06-22 23:34:09 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-24 19:40:25 +0200
commit903d8d84919f786cdf11f057b2d5c5ca920bad5d (patch)
treebb8ee66f62f6cbd739cd27466414a876902595f7 /dev-python/rtimulib
parentsys-libs/obstack-standalone: stable on amd64, arm, ppc and x86 (diff)
downloadgentoo-903d8d84919f786cdf11f057b2d5c5ca920bad5d.tar.gz
gentoo-903d8d84919f786cdf11f057b2d5c5ca920bad5d.tar.bz2
gentoo-903d8d84919f786cdf11f057b2d5c5ca920bad5d.zip
dev-python/rtimulib: New package
Closes: https://bugs.gentoo.org/571232 Closes: https://github.com/gentoo/gentoo/pull/7308 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/rtimulib')
-rw-r--r--dev-python/rtimulib/Manifest1
-rw-r--r--dev-python/rtimulib/metadata.xml12
-rw-r--r--dev-python/rtimulib/rtimulib-7.2.1.ebuild22
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/rtimulib/Manifest b/dev-python/rtimulib/Manifest
new file mode 100644
index 000000000000..0858d126a285
--- /dev/null
+++ b/dev-python/rtimulib/Manifest
@@ -0,0 +1 @@
+DIST RTIMULib-7.2.1.tar.gz 915114 BLAKE2B 5d8a54d4b1083105c1bb3b854e8474cb81cfd5eff843422e2f66f363ae04dd9e87d4cffc8f26c2a68c4f535d77ca229bc7bb7840c59ba3c6d2d45d5ee7f31987 SHA512 2a9d40f5c4db7c875fe82bd79408d97f9b00a3cd0d1be9b19baa3808b4cd260200b8ce5f5d9a6298df760aaca10555eb317d4a2431cd1c07a1b7953448852b23
diff --git a/dev-python/rtimulib/metadata.xml b/dev-python/rtimulib/metadata.xml
new file mode 100644
index 000000000000..54d5423c4060
--- /dev/null
+++ b/dev-python/rtimulib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/rtimulib/rtimulib-7.2.1.ebuild b/dev-python/rtimulib/rtimulib-7.2.1.ebuild
new file mode 100644
index 000000000000..06ba1a373675
--- /dev/null
+++ b/dev-python/rtimulib/rtimulib-7.2.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_P="RTIMULib-${PV}"
+
+DESCRIPTION="Python Binding for RTIMULib, a versatile IMU library"
+HOMEPAGE="https://github.com/RPi-Distro/RTIMULib"
+SRC_URI="https://github.com/RPi-Distro/RTIMULib/archive/V${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}/Linux/python"