summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiogo Pereira <sir.suriv@gmail.com>2016-08-06 23:18:59 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 19:18:14 +0200
commitf73c27503f9a144a73ff160d5b03c33ea80ba406 (patch)
treec88949eb59c14e282dc901bee925f186e23f5f99 /dev-python/rtslib
parentdev-python/configshell: update live ebuild (diff)
downloadgentoo-f73c27503f9a144a73ff160d5b03c33ea80ba406.tar.gz
gentoo-f73c27503f9a144a73ff160d5b03c33ea80ba406.tar.bz2
gentoo-f73c27503f9a144a73ff160d5b03c33ea80ba406.zip
dev-python/rtslib: update live ebuild
* Bump to EAPI 6 * Update git repository URI * Change license to Apache-2.0 * Add DEPEND on dev-python/pyparsing Closes: https://github.com/gentoo/gentoo/pull/2034 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/rtslib')
-rw-r--r--dev-python/rtslib/rtslib-9999.ebuild32
1 files changed, 20 insertions, 12 deletions
diff --git a/dev-python/rtslib/rtslib-9999.ebuild b/dev-python/rtslib/rtslib-9999.ebuild
index 361b6018735d..df18a05c3de1 100644
--- a/dev-python/rtslib/rtslib-9999.ebuild
+++ b/dev-python/rtslib/rtslib-9999.ebuild
@@ -1,29 +1,37 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="git://linux-iscsi.org/${PN}.git"
PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 git-2
+inherit distutils-r1
DESCRIPTION="RTSLib Community Edition for target_core_mod/ConfigFS"
-HOMEPAGE="http://linux-iscsi.org/"
-SRC_URI=""
+HOMEPAGE="http://linux-iscsi.org/wiki/targetcli"
-LICENSE="AGPL-3"
+LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS=""
IUSE=""
-DEPEND="
- dev-python/configobj[${PYTHON_USEDEP}]
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/Datera/${PN}.git
+ https://github.com/Datera/${PN}.git"
+ KEYWORDS=""
+else
+ MY_PV=${PV/_/-}
+ SRC_URI="https://github.com/Datera/${PN}/archive/${PV/_/-}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="dev-python/configobj[${PYTHON_USEDEP}]
dev-python/ipaddr[${PYTHON_USEDEP}]
dev-python/netifaces[${PYTHON_USEDEP}]
- !dev-python/rtslib-fb[${PYTHON_USEDEP}]
- "
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ !dev-python/rtslib-fb"
RDEPEND="${DEPEND}"
src_install() {