summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-04 07:09:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-04 07:09:04 +0200
commit899b1ab04fb61c8e4378d5d059ce6844c684d4cf (patch)
tree78a4605a27b7e907b2ce23e428bf244ec4e563cd /dev-python/ruamel-yaml
parentdev-python/sqlglot: Bump to 18.11.2 (diff)
downloadgentoo-899b1ab04fb61c8e4378d5d059ce6844c684d4cf.tar.gz
gentoo-899b1ab04fb61c8e4378d5d059ce6844c684d4cf.tar.bz2
gentoo-899b1ab04fb61c8e4378d5d059ce6844c684d4cf.zip
dev-python/ruamel-yaml: Bump to 0.17.34
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.34.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index 9f11cb78a80a..f67e56260686 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,2 +1,3 @@
DIST ruamel.yaml-0.17.32.tar.xz 190144 BLAKE2B fe58904cacff21bd64eb7e9cc4ea613ae0ad8e6718f568f64876385b70b6c2ce2bc6137537ddf9d3c7e9c08c66a1112f78527080c025fb5655ddce2b73a4f477 SHA512 e78ae975c3a7281d69ca965604fbc7f014cf8aaec9e51e27c795caefc5708019c57629f54044b12833bca0c846a8005fc0b95e64f75b2da226cdca2fefbcd8ae
DIST ruamel.yaml-0.17.33.tar.xz 190420 BLAKE2B 93a91f1ad6e17bf0a4f6d90e782786aafe959f298c4bf109c62450fbb42df79908f9037b8e7535dbcb33eacbef0680fec72a800918045c01b427eba07bb32090 SHA512 75b13e920298b729ce9ac764162864eaf8492795b3ae3bad7dfe1ad4e5cc92e84ae5063859ae694d6334bb3e9660ba68cbf56888674f98ac787ff10266373e15
+DIST ruamel.yaml-0.17.34.tar.xz 190824 BLAKE2B e396b59f94a18e77e7bd3d42cc8f934b8b2c8adbd1292861dde18136bc6aa585e4ba90db0b4631f15737c9c2d8fc49ca8fd2d12bc7b5a96e6a2672db7c87ba0f SHA512 7b5098b3e3aa6aa38158626a139fe98e1c90d37870a81ade50b0dd446a5b772623a7759ff0dccee2a1346ed442bcaabe4be34af9f5760b4bfb91cce46673b5c1
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.34.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.34.ebuild
new file mode 100644
index 000000000000..128dbc52c0bb
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.34.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}