summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-21 05:35:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-21 05:35:25 +0200
commit8bf76251b24fcf888a633a70d79f874ef0c46b53 (patch)
treed9558b1b1c5c6a245c6ae838a0ec0c781c3f0037 /dev-python/ruamel-yaml
parentdev-python/scikit-build-core: Bump to 0.6.0 (diff)
downloadgentoo-8bf76251b24fcf888a633a70d79f874ef0c46b53.tar.gz
gentoo-8bf76251b24fcf888a633a70d79f874ef0c46b53.tar.bz2
gentoo-8bf76251b24fcf888a633a70d79f874ef0c46b53.zip
dev-python/ruamel-yaml: Bump to 0.17.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index f56105d44f40..a975db8ea5ec 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -4,3 +4,4 @@ DIST ruamel.yaml-0.17.34.tar.xz 190824 BLAKE2B e396b59f94a18e77e7bd3d42cc8f934b8
DIST ruamel.yaml-0.17.35.tar.xz 191432 BLAKE2B 7fe4a44aeebe4e82202277139056f4046c6c7636b75c77202fd3bd4d71b3276890bd4ea30997c3acc634f0a8f7e482f4c81145749e1e37ac59ad53421aaa518a SHA512 4f5218b8ad9172a925e29e0b46d055b6b6dc57b9685a31e7e4147d1f7bcc908c73a05a350fd6d85016ea4d8bde13705e5f8d5866aa9087a34e3f648ff0460311
DIST ruamel.yaml-0.17.36.tar.xz 193148 BLAKE2B 20c7389b29a34a917049c1ef1081ac7d349608435b2bdea03a390a6db979feefe1a1926db73bdee4cff100c605fa594c65ee23c64a0db45ce8230745d10945da SHA512 dce0cefec0b89cfb48d2124e2f18d4dbd9d67cca1af2cb556c308548f25dba932b129e62d3b5b666bfbed52838e0e16e3e4ae549689155b6314667d565b7bae2
DIST ruamel.yaml-0.17.39.tar.xz 192916 BLAKE2B 23553af89c3083837a54805097c2c59eb2bff96e200acd12fcc646bf346eab20d87f58e6c9553598615a750d408dc855886fe4251ba128e3325cecb953f18275 SHA512 ee534cff9a6b72b617faf3fb4044bff0ae2d3c29508ef8df948774db45d39c8f80362f7ed8c8091319718a221b9d462838d521d97603d9cb18c38a008ebec8e5
+DIST ruamel.yaml-0.17.40.tar.xz 193424 BLAKE2B 80405ef0c85af476ef0e996b1da5aba1a116e8c181d18f40fb4fd86093a512c09cf0da30d52d85946c524e86e10379cb11154cb08a7ea7b054ba9379996de4f4 SHA512 848af49430b9c028a6676a159915c66e29f4290374ba0863e4fd87527f3178bb303a80f4ba97139fc8cbcd01f7f7782a4b3112325237a39659e227afda61fcb8
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
new file mode 100644
index 000000000000..128dbc52c0bb
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.40.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}