summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-02 14:27:30 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-02 14:27:30 +0100
commit9a06165276e3111d36d2fc40a0b1813cd08dcea2 (patch)
tree91dbeae9c96ff40a52598db13c7a91ae9929ef02 /dev-python/ruamel-yaml
parentdev-python/Faker: Bump to 19.13.0 (diff)
downloadgentoo-9a06165276e3111d36d2fc40a0b1813cd08dcea2.tar.gz
gentoo-9a06165276e3111d36d2fc40a0b1813cd08dcea2.tar.bz2
gentoo-9a06165276e3111d36d2fc40a0b1813cd08dcea2.zip
dev-python/ruamel-yaml: Bump to 0.18.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.18.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index f4c20f004fc1..cc39106b1cd5 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -1,2 +1,3 @@
DIST ruamel.yaml-0.17.40.tar.xz 193424 BLAKE2B 80405ef0c85af476ef0e996b1da5aba1a116e8c181d18f40fb4fd86093a512c09cf0da30d52d85946c524e86e10379cb11154cb08a7ea7b054ba9379996de4f4 SHA512 848af49430b9c028a6676a159915c66e29f4290374ba0863e4fd87527f3178bb303a80f4ba97139fc8cbcd01f7f7782a4b3112325237a39659e227afda61fcb8
DIST ruamel.yaml-0.18.3.tar.xz 195928 BLAKE2B e0986dfdf45b67baab83a49f5380f43a87c388a5b6ebe06ee0518013630e9577cbf06dc9457b53a10a74af13b3e976593fae08d19fb2ff242e35ca6238aaecc9 SHA512 80d9032cb67a434633b61fb321b82dd39403058c8bcab4480ddca7053801722d5763765de426f68fcd5a2ef923f98ca29c4efdd4f749a52872ef10ddf7a8cd6e
+DIST ruamel.yaml-0.18.4.tar.xz 197060 BLAKE2B 7ae048fce52979268fbdf5a3779fc6068b713d04e27bfd70d167208f967a9e96682b4e0b54011f44a205597ccd95227a7bc40b9d4e814bcd836e9b57e8c58ff4 SHA512 d9cf0572b6d29c3c7f6ee0e7a638f4f0df5c3c9005c69a666a7b7ddb378f97ff7a9be52f6576b1b2e2bca9ff5edde209cd7577ed4b4bf1ac4dd15c9efad6f547
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.18.4.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.18.4.ebuild
new file mode 100644
index 000000000000..128dbc52c0bb
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.18.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}