summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-19 14:12:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-19 14:13:59 +0200
commitab526ec603392fce6b3278dcbe8e6658f31e3088 (patch)
tree9b4cd6b9e419fd491e2fba2086f92cfe11326e67 /dev-python/ruamel-yaml
parentdev-python/paste: Bump to 3.7.1 (diff)
downloadgentoo-ab526ec603392fce6b3278dcbe8e6658f31e3088.tar.gz
gentoo-ab526ec603392fce6b3278dcbe8e6658f31e3088.tar.bz2
gentoo-ab526ec603392fce6b3278dcbe8e6658f31e3088.zip
dev-python/ruamel-yaml: Bump to 0.17.36
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/ruamel-yaml')
-rw-r--r--dev-python/ruamel-yaml/Manifest1
-rw-r--r--dev-python/ruamel-yaml/ruamel-yaml-0.17.36.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/ruamel-yaml/Manifest b/dev-python/ruamel-yaml/Manifest
index d5a160eb26a6..60fcbf912004 100644
--- a/dev-python/ruamel-yaml/Manifest
+++ b/dev-python/ruamel-yaml/Manifest
@@ -2,3 +2,4 @@ DIST ruamel.yaml-0.17.32.tar.xz 190144 BLAKE2B fe58904cacff21bd64eb7e9cc4ea613ae
DIST ruamel.yaml-0.17.33.tar.xz 190420 BLAKE2B 93a91f1ad6e17bf0a4f6d90e782786aafe959f298c4bf109c62450fbb42df79908f9037b8e7535dbcb33eacbef0680fec72a800918045c01b427eba07bb32090 SHA512 75b13e920298b729ce9ac764162864eaf8492795b3ae3bad7dfe1ad4e5cc92e84ae5063859ae694d6334bb3e9660ba68cbf56888674f98ac787ff10266373e15
DIST ruamel.yaml-0.17.34.tar.xz 190824 BLAKE2B e396b59f94a18e77e7bd3d42cc8f934b8b2c8adbd1292861dde18136bc6aa585e4ba90db0b4631f15737c9c2d8fc49ca8fd2d12bc7b5a96e6a2672db7c87ba0f SHA512 7b5098b3e3aa6aa38158626a139fe98e1c90d37870a81ade50b0dd446a5b772623a7759ff0dccee2a1346ed442bcaabe4be34af9f5760b4bfb91cce46673b5c1
DIST ruamel.yaml-0.17.35.tar.xz 191432 BLAKE2B 7fe4a44aeebe4e82202277139056f4046c6c7636b75c77202fd3bd4d71b3276890bd4ea30997c3acc634f0a8f7e482f4c81145749e1e37ac59ad53421aaa518a SHA512 4f5218b8ad9172a925e29e0b46d055b6b6dc57b9685a31e7e4147d1f7bcc908c73a05a350fd6d85016ea4d8bde13705e5f8d5866aa9087a34e3f648ff0460311
+DIST ruamel.yaml-0.17.36.tar.xz 193148 BLAKE2B 20c7389b29a34a917049c1ef1081ac7d349608435b2bdea03a390a6db979feefe1a1926db73bdee4cff100c605fa594c65ee23c64a0db45ce8230745d10945da SHA512 dce0cefec0b89cfb48d2124e2f18d4dbd9d67cca1af2cb556c308548f25dba932b129e62d3b5b666bfbed52838e0e16e3e4ae549689155b6314667d565b7bae2
diff --git a/dev-python/ruamel-yaml/ruamel-yaml-0.17.36.ebuild b/dev-python/ruamel-yaml/ruamel-yaml-0.17.36.ebuild
new file mode 100644
index 000000000000..128dbc52c0bb
--- /dev/null
+++ b/dev-python/ruamel-yaml/ruamel-yaml-0.17.36.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P="${P/-/.}"
+DESCRIPTION="YAML parser/emitter that supports roundtrip comment preservation"
+HOMEPAGE="
+ https://pypi.org/project/ruamel.yaml/
+ https://sourceforge.net/projects/ruamel-yaml/
+"
+# PyPI tarballs do not include tests
+SRC_URI="mirror://sourceforge/ruamel-dl-tagged-releases/${MY_P}.tar.xz"
+S="${WORKDIR}"/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/ruamel-yaml-clib[${PYTHON_USEDEP}]
+ !dev-python/namespace-ruamel
+"
+BDEPEND="
+ test? (
+ dev-python/ruamel-std-pathlib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
+ _test/test_deprecation.py::test_collections_deprecation
+ )
+ local EPYTEST_IGNORE=(
+ # Old PyYAML tests from lib/ require special set-up and are
+ # invoked indirectly via test_z_olddata, tell pytest itself
+ # to leave the subdir alone.
+ _test/lib/
+ )
+
+ # this is needed to keep the tests working while
+ # dev-python/namespace-ruamel is still installed
+ distutils_write_namespace ruamel
+ epytest
+}