summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:43:13 +0000
committerBrian Dolbec <dolsen@gentoo.org>2017-08-01 18:51:23 +0000
commit9347bdb6889ef19d790e7933be1878ac237c0e65 (patch)
treee78ecda39435cc221455e60b52c8a508ee9f0468 /dev-python/sdnotify
parentdev-python/shutilwhich: New pkg, dep of new pkg dev-python/crossbar (diff)
downloadgentoo-9347bdb6889ef19d790e7933be1878ac237c0e65.tar.gz
gentoo-9347bdb6889ef19d790e7933be1878ac237c0e65.tar.bz2
gentoo-9347bdb6889ef19d790e7933be1878ac237c0e65.zip
dev-python/sdnotify: New pkg, dep of new pkg dev-python/crossbar
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-python/sdnotify')
-rw-r--r--dev-python/sdnotify/Manifest1
-rw-r--r--dev-python/sdnotify/metadata.xml24
-rw-r--r--dev-python/sdnotify/sdnotify-0.3.1.ebuild22
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/sdnotify/Manifest b/dev-python/sdnotify/Manifest
new file mode 100644
index 000000000000..d26bbdd3afff
--- /dev/null
+++ b/dev-python/sdnotify/Manifest
@@ -0,0 +1 @@
+DIST sdnotify-0.3.1.tar.gz 2513 SHA256 e69220d4f6cbb02130f43f929350a80cf51033fde47dcb056fbda71e2dff2d5a SHA512 765e75e727ad5128269bfffd4d3f64666df654adc50965a54f3cd622933aca583faee5453f7fec3a23b6f754f4475522dd96a86ba643984cd72a575ec082709c WHIRLPOOL b43831604022cdd5f605138324cda4e43ee7021993e66afaa73b82eff98c11dc087d5f8f5d1b62073d750cfb84ac9168eca12640dc6149df68506826fcbfc0c4
diff --git a/dev-python/sdnotify/metadata.xml b/dev-python/sdnotify/metadata.xml
new file mode 100644
index 000000000000..24bc40f11d18
--- /dev/null
+++ b/dev-python/sdnotify/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <description>Primary maintainer</description>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>bbethke@gmail.com</email>
+ <name>Brett Bethke</name>
+ </maintainer>
+ <remote-id type="pypi">sdnotify</remote-id>
+ <remote-id type="github">bb4242/sdnotify</remote-id>
+ </upstream>
+ <longdescription>
+ This is a pure Python implementation of the systemd sd_notify
+ protocol. This protocol can be used to inform systemd about
+ service start-up completion, watchdog events, and other service
+ status changes. Thus, this package can be used to write system
+ services in Python that play nicely with systemd. sdnotify is
+ compatible with both Python 2 and Python 3.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/sdnotify/sdnotify-0.3.1.ebuild b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
new file mode 100644
index 000000000000..7e034a96ad4b
--- /dev/null
+++ b/dev-python/sdnotify/sdnotify-0.3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of systemd's service notification protocol (sd_notify)"
+HOMEPAGE="
+ https://github.com/bb4242/sdnotify
+ https://pypi.python.org/pypi/sdnotify"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"