summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2016-12-05 12:36:13 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-10 22:55:42 +0100
commite83af315c69252fc0f4614c300003ab776b2dd1a (patch)
treefe94cb97fcd9921d7d7d45dba39f7c3ca39a6548 /dev-python/seaborn/seaborn-0.7.1.ebuild
parentwww-misc/shellinabox: reduce scope of a couple of variables in init script. (diff)
downloadgentoo-e83af315c69252fc0f4614c300003ab776b2dd1a.tar.gz
gentoo-e83af315c69252fc0f4614c300003ab776b2dd1a.tar.bz2
gentoo-e83af315c69252fc0f4614c300003ab776b2dd1a.zip
dev-python/seaborn: version bump.
Package-Manager: portage-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/3020
Diffstat (limited to 'dev-python/seaborn/seaborn-0.7.1.ebuild')
-rw-r--r--dev-python/seaborn/seaborn-0.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/seaborn/seaborn-0.7.1.ebuild b/dev-python/seaborn/seaborn-0.7.1.ebuild
new file mode 100644
index 000000000000..a3ae6e57212d
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="http://stanford.edu/~mwaskom/software/seaborn/ https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cat > matplotlibrc <<- EOF
+ backend : Agg
+ EOF
+ virtx nosetests --verbosity=3
+}