summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2020-09-13 17:09:16 +0200
committerDavid Seifert <soap@gentoo.org>2020-09-13 17:09:16 +0200
commit3a729a812f822bcfffca043f88f559b550b8d0be (patch)
treebb1b15f0150d670eb72504c573e4dedb487d38b5 /dev-python/seaborn
parentdev-libs/vc-intrinsics: new package (diff)
downloadgentoo-3a729a812f822bcfffca043f88f559b550b8d0be.tar.gz
gentoo-3a729a812f822bcfffca043f88f559b550b8d0be.tar.bz2
gentoo-3a729a812f822bcfffca043f88f559b550b8d0be.zip
dev-python/seaborn: version bump 0.10.1
Bug: https://bugs.gentoo.org/738374 Closes: https://github.com/gentoo/gentoo/pull/17222 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Horea Christian <chr@chymera.eu> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-python/seaborn')
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/seaborn-0.10.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index d2e6845d202b..484b7e818d76 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1 +1,2 @@
DIST seaborn-0.10.0.tar.gz 194113 BLAKE2B 7e5d6efd7a8446172a3f102c2c7815483f5e24cd2698f52e70186395468a782e45e1cc8fa7eacf7e2956b66e2a6cda76525973b2fecdc43a784af85319c9f5fa SHA512 1f6288931cb63d3109663b5aedc7c11b6b97a6afd8cf9b9e94a9a1f4e18c45456ae7bb055c5be0fb0c34dbb3fdf992d7a88bc1cb88506bebf9ddf9bf685aa3ea
+DIST seaborn-0.10.1.tar.gz 193770 BLAKE2B f23271b222d409464853ab8f853e17e462890d6f00ca222bcc40d681ff815ef9f1e545e8693f2d33ceeaed51bd6e21ff7edb72835813d4813fffebfa80c84e00 SHA512 167d44d7d64936e15e6c9061cc6bd53a40c0a3e4d619f936ae58de745d5f5273ee8acbd470d3ac155639aac072356a2c2655dff511c4be7d041c3528ab35386f
diff --git a/dev-python/seaborn/seaborn-0.10.1.ebuild b/dev-python/seaborn/seaborn-0.10.1.ebuild
new file mode 100644
index 000000000000..3075fc84222b
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.10.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="https://seaborn.pydata.org https://github.com/mwaskom/seaborn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ <dev-python/matplotlib-3.3.0[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.13.3[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.22.0[${PYTHON_USEDEP}]
+ dev-python/patsy[${PYTHON_USEDEP}]
+ dev-python/statsmodels[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.0.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+ pytest -vv || die
+}