summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-15 13:55:17 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-15 13:58:50 -0600
commite19f46dfca967f4195eedf3f37a7882fbb37b796 (patch)
treea89187aaf070cb1616090703c3a7cd955ded29b7 /dev-python/secretstorage/secretstorage-2.3.1.ebuild
parentkde-apps: Remove KDE Applications 16.08.2 (diff)
downloadgentoo-e19f46dfca967f4195eedf3f37a7882fbb37b796.tar.gz
gentoo-e19f46dfca967f4195eedf3f37a7882fbb37b796.tar.bz2
gentoo-e19f46dfca967f4195eedf3f37a7882fbb37b796.zip
dev-python/secretstorage: adding for keyring
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/secretstorage/secretstorage-2.3.1.ebuild')
-rw-r--r--dev-python/secretstorage/secretstorage-2.3.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/secretstorage/secretstorage-2.3.1.ebuild b/dev-python/secretstorage/secretstorage-2.3.1.ebuild
new file mode 100644
index 000000000000..3bb5c78837df
--- /dev/null
+++ b/dev-python/secretstorage/secretstorage-2.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="SecretStorage"
+
+DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
+HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.python.org/pypi/SecretStorage"
+SRC_URI="mirror://pypi/S/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"