summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-05-15 18:06:25 +0200
committerSebastian Pipping <sping@gentoo.org>2019-05-15 18:06:41 +0200
commit97037e3b3f55b548a22455295217783c2ee52bd5 (patch)
tree19d87b9b7708d92ecc5e3fc154d8503c3266980e /dev-python/secretstorage/secretstorage-3.1.1.ebuild
parentmedia-video/rtmpdump: arm stable wrt bug #684614 (diff)
downloadgentoo-97037e3b3f55b548a22455295217783c2ee52bd5.tar.gz
gentoo-97037e3b3f55b548a22455295217783c2ee52bd5.tar.bz2
gentoo-97037e3b3f55b548a22455295217783c2ee52bd5.zip
dev-python/secretstorage: 3.1.1
Closes: https://bugs.gentoo.org/684332 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.65, Repoman-2.3.12
Diffstat (limited to 'dev-python/secretstorage/secretstorage-3.1.1.ebuild')
-rw-r--r--dev-python/secretstorage/secretstorage-3.1.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/secretstorage/secretstorage-3.1.1.ebuild b/dev-python/secretstorage/secretstorage-3.1.1.ebuild
new file mode 100644
index 000000000000..d05e995ee3db
--- /dev/null
+++ b/dev-python/secretstorage/secretstorage-3.1.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{5,6,7} )
+
+inherit distutils-r1
+
+MY_PN="SecretStorage"
+
+DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
+HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/alabaster[${PYTHON_USEDEP}]
+ )
+ test? ( ${RDEPEND} )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
+ || die "tests failed with ${EPYTHON}"
+}