summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-12-04 11:28:25 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-12-04 12:05:14 -0800
commit15f82f080f6978b9446e07b2b834d23c885cdf6a (patch)
tree99c81e2ea8c1ee95493058285780054d1457aa57 /dev-python/secretstorage
parentdev-python/jeepney-0.4.1: Version bump, add py38 (diff)
downloadgentoo-15f82f080f6978b9446e07b2b834d23c885cdf6a.tar.gz
gentoo-15f82f080f6978b9446e07b2b834d23c885cdf6a.tar.bz2
gentoo-15f82f080f6978b9446e07b2b834d23c885cdf6a.zip
dev-python/secretstorage-3.1.1-r1: revbump, add py38, use distutils-r1 helpers
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/secretstorage')
-rw-r--r--dev-python/secretstorage/secretstorage-3.1.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/secretstorage/secretstorage-3.1.1-r1.ebuild b/dev-python/secretstorage/secretstorage-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..4c7bdeef370c
--- /dev/null
+++ b/dev-python/secretstorage/secretstorage-3.1.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{5,6,7,8} )
+
+inherit distutils-r1
+
+MY_PN="SecretStorage"
+
+DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
+HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/jeepney[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+python_test() {
+ dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
+ || die "tests failed with ${EPYTHON}"
+}